summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohan Dahlin <johan@src.gnome.org>2004-07-17 16:38:46 +0000
committerJohan Dahlin <johan@src.gnome.org>2004-07-17 16:38:46 +0000
commita565ad51fe4d189ed0bc85bde14bf3aa87f2f344 (patch)
tree70be806b8e19117619961a07def10dc931d7d5f7 /Makefile.am
parent2fa0940002a5ebe976d88e3c9397a1fb5cb5486d (diff)
downloadpygtk-a565ad51fe4d189ed0bc85bde14bf3aa87f2f344.tar.gz
gtk/*.override
* gtk/*.override * codegen/codegen.py: * codegen/argtypes.py: Update for enums * pygtype.c (pyg_value_as_pyobject): Use new enum/flag functions * pygenum.[ch]: Handle GFlag * pygflags.[ch]: Handle GFlag * atk-types.defs: Fix gtype-id for all enums * gobjectmodule.c (initgobject): Clean up and add convinience macros * tests/enum.py: New file * tests/common.py: New file, also stole from gst-python
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index c996dd30..a5dbbf57 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
# require automake-1.7
AUTOMAKE_OPTIONS = 1.7
-SUBDIRS = codegen gtk docs
+SUBDIRS = codegen gtk docs tests
CLEANFILES =
EXTRA_DIST = $(defs_DATA)
@@ -53,8 +53,16 @@ endif
gobject_la_LDFLAGS = $(common_ldflags) -export-symbols-regex initgobject
gobject_la_LIBADD = $(GLIB_LIBS)
gobject_la_SOURCES = \
- pygobject.h pygobject-private.h \
- gobjectmodule.c pygtype.c pygobject.c pygboxed.c
+ gobjectmodule.c \
+ pygboxed.c \
+ pygenum.c \
+ pygenum.h \
+ pygflags.c \
+ pygflags.h \
+ pygobject.c \
+ pygobject.h \
+ pygobject-private.h \
+ pygtype.c
# pango module
pango_la_LDFLAGS = $(common_ldflags) -export-symbols-regex initpango