summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohan Dahlin <johan@src.gnome.org>2006-01-09 13:12:27 +0000
committerJohan Dahlin <johan@src.gnome.org>2006-01-09 13:12:27 +0000
commitb559647ef6cdcfbaa9595c6d73dbea20f7f213c5 (patch)
tree20ad393680d9bff1e55c994e861fd4b1341bd428 /Makefile.am
parent5ad3835c0dfe886ac26f10b509ef9832bb3889d4 (diff)
downloadpygtk-b559647ef6cdcfbaa9595c6d73dbea20f7f213c5.tar.gz
Remove gobject bindings and depend on pygobject 2.9.0.
Bump version to 2.9.0
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 4 insertions, 23 deletions
diff --git a/Makefile.am b/Makefile.am
index a52c342d..92b0ee57 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,7 @@ if BUILD_GTK
GTK_SUBDIR = gtk
endif
-SUBDIRS = codegen gobject . $(GTK_SUBDIR) docs examples tests
+SUBDIRS = codegen . $(GTK_SUBDIR) docs examples tests
PLATFORM_VERSION = 2.0
@@ -13,7 +13,6 @@ EXTRA_DIST = \
ChangeLog.pre-2-0 \
ChangeLog.pre-2-6 \
config.h.win32 \
- dsextras.py \
MANIFEST.in \
MAPPING \
pygtk.spec \
@@ -24,11 +23,11 @@ EXTRA_DIST = \
PKG-INFO.in \
setup.py \
THREADS
-INCLUDES = $(PYTHON_INCLUDES) $(GLIB_CFLAGS) -I$(top_srcdir)/gobject
+INCLUDES = $(PYTHON_INCLUDES) $(GLIB_CFLAGS) $(PYGOBJECT_CFLAGS)
# pkg-config files
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = pygobject-$(PLATFORM_VERSION).pc
+pkgconfig_DATA =
if BUILD_GTK
pkgconfig_DATA += pygtk-$(PLATFORM_VERSION).pc
endif
@@ -38,17 +37,9 @@ defsdir = $(pkgdatadir)/$(PLATFORM_VERSION)/defs
defs_DATA =
# python
-pyexec_PYTHON = pygtk.py
pyexec_LTLIBRARIES =
-noinst_PYTHON = ltihooks.py
-
-# pygtk scripts
-pkgpythondir = $(pyexecdir)/gtk-2.0
-pkgpython_PYTHON = dsextras.py
-
-# pygtk extension modules
-pkgpyexecdir = $(pyexecdir)/gtk-2.0
pkgpyexec_LTLIBRARIES =
+noinst_PYTHON = ltihooks.py
# linker flags
common_ldflags = -module -avoid-version
@@ -112,15 +103,5 @@ endif
&& cp gen-$*.c $*.c \
&& rm -f gen-$*.c
-# install pth file.
-install-data-local:
- $(mkinstalldirs) $(DESTDIR)$(pythondir)
- echo "gtk-$(PLATFORM_VERSION)" > $(DESTDIR)$(pyexecdir)/pygtk.pth
-install-exec-local:
- $(mkinstalldirs) $(DESTDIR)$(pyexecdir)
- echo "gtk-$(PLATFORM_VERSION)" > $(DESTDIR)$(pyexecdir)/pygtk.pth
-uninstall-local:
- rm -f $(DESTDIR)$(pythondir)/pygtk.pth $(DESTDIR)$(pyexecdir)/pygtk.pth
-
snap:
$(MAKE) dist distdir=$(PACKAGE)-SNAP-`date +"%Y%m%d"`