summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Henstridge <james@daa.com.au>2000-06-27 14:39:12 +0000
committerJames Henstridge <jamesh@src.gnome.org>2000-06-27 14:39:12 +0000
commitbd0def79e97bb5a2c69ab5bc35719573ee121e82 (patch)
tree37ef9b717ad2ac6bdc8acd86a006a07df56e1bb6 /Makefile.am
parent7acf814199ee3e7326b97652ae3b17b2963f90f4 (diff)
downloadpygtk-bd0def79e97bb5a2c69ab5bc35719573ee121e82.tar.gz
start of gobject wrapper.
2000-06-27 James Henstridge <james@daa.com.au> * gobjectmodule.c (pygobject_dealloc): start of gobject wrapper.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 889fbf27..d0829c1d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,16 +3,21 @@ AUTOMAKE_OPTIONS = 1.4a
SUBDIRS = codegen gtk
-INCLUDES = $(PYTHON_INCLUDES)
+INCLUDES = $(PYTHON_INCLUDES) $(GLIB_CFLAGS)
pyexecdir = $(PYTHON_SITE_EXEC)
-pyexec_LTLIBRARIES = ExtensionClass.la
+pyexec_LTLIBRARIES = ExtensionClass.la gobjectmodule.la
ExtensionClass_la_LDFLAGS = -module -avoid-version
ExtensionClass_la_SOURCES = \
ExtensionClass.h \
ExtensionClass.c
+gobjectmodule_la_LDFLAGS = -module -avoid-version
+gobjectmodule_la_SOURCES = \
+ gobjectmodule.c
+gobjectmodule_la_LIBADD = $(GLIB_LIBS)
+
noinst_PYTHON = ltihooks.py
EXTRA_DIST = \