summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGustavo J. A. M. Carneiro <gjc@src.gnome.org>2006-01-09 23:00:43 +0000
committerGustavo J. A. M. Carneiro <gjc@src.gnome.org>2006-01-09 23:00:43 +0000
commitc5f4c9acb1eeae5e6227b03ce266d49d972784b6 (patch)
treec9b2e0f45d6f5aaa253399db4068ddcc2b14e4e6 /Makefile.am
parent81608306deb5456b6d872aac8c80cb7c30e93ba6 (diff)
downloadpygtk-c5f4c9acb1eeae5e6227b03ce266d49d972784b6.tar.gz
Don't build or install gobject bindings if pygobject >= 2.9 is found
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a52c342d..e76a4a56 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,13 @@ if BUILD_GTK
GTK_SUBDIR = gtk
endif
-SUBDIRS = codegen gobject . $(GTK_SUBDIR) docs examples tests
+SUBDIRS = codegen
+
+if BUILD_GOBJECT
+ SUBDIRS += gobject
+endif
+
+SUBDIRS += . $(GTK_SUBDIR) docs examples tests
PLATFORM_VERSION = 2.0
@@ -28,7 +34,10 @@ INCLUDES = $(PYTHON_INCLUDES) $(GLIB_CFLAGS) -I$(top_srcdir)/gobject
# pkg-config files
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = pygobject-$(PLATFORM_VERSION).pc
+pkgconfig_DATA =
+if BUILD_GOBJECT
+pkgconfig_DATA += pygobject-$(PLATFORM_VERSION).pc
+endif
if BUILD_GTK
pkgconfig_DATA += pygtk-$(PLATFORM_VERSION).pc
endif
@@ -38,13 +47,17 @@ defsdir = $(pkgdatadir)/$(PLATFORM_VERSION)/defs
defs_DATA =
# python
+if BUILD_GOBJECT
pyexec_PYTHON = pygtk.py
+endif
pyexec_LTLIBRARIES =
noinst_PYTHON = ltihooks.py
# pygtk scripts
+if BUILD_GOBJECT
pkgpythondir = $(pyexecdir)/gtk-2.0
pkgpython_PYTHON = dsextras.py
+endif
# pygtk extension modules
pkgpyexecdir = $(pyexecdir)/gtk-2.0