summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohan Dahlin <johan@src.gnome.org>2006-04-01 17:09:57 +0000
committerJohan Dahlin <johan@src.gnome.org>2006-04-01 17:09:57 +0000
commitdca42f447c6a80eb99c475beeedfee08b6454924 (patch)
tree7209b552f7be914a64a9358a50fe42ef2eeb9a01 /Makefile.am
parent131ec457942583532ed6d2600d26c241440ba4af (diff)
downloadpygtk-dca42f447c6a80eb99c475beeedfee08b6454924.tar.gz
Remove gobject and depend on pygobject 2.10.0
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am41
1 files changed, 6 insertions, 35 deletions
diff --git a/Makefile.am b/Makefile.am
index b550f1b0..9dad0a35 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,13 +4,7 @@ if BUILD_GTK
GTK_SUBDIR = gtk
endif
-SUBDIRS = codegen
-
-if BUILD_GOBJECT
- SUBDIRS += gobject
-endif
-
-SUBDIRS += . $(GTK_SUBDIR) docs examples tests
+SUBDIRS = codegen . $(GTK_SUBDIR) docs examples tests
PLATFORM_VERSION = 2.0
@@ -19,7 +13,6 @@ EXTRA_DIST = \
ChangeLog.pre-2-0 \
ChangeLog.pre-2-6 \
config.h.win32 \
- dsextras.py \
MANIFEST.in \
MAPPING \
pygtk.spec \
@@ -30,19 +23,15 @@ EXTRA_DIST = \
PKG-INFO.in \
setup.py \
THREADS
-INCLUDES = $(PYTHON_INCLUDES) $(GLIB_CFLAGS)
-if BUILD_GOBJECT
- INCLUDES += -I$(top_srcdir)/gobject
-else
- INCLUDES += -I$(PYGOBJECT_INCLUDEDIR)
-endif
+
+INCLUDES = \
+ $(PYTHON_INCLUDES) \
+ $(PYGOBJECT_CFLAGS) \
+ $(GLIB_CFLAGS)
# pkg-config files
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA =
-if BUILD_GOBJECT
-pkgconfig_DATA += pygobject-$(PLATFORM_VERSION).pc
-endif
pkgconfig_DATA += pygtk-$(PLATFORM_VERSION).pc
# defs files
@@ -50,17 +39,11 @@ defsdir = $(pkgdatadir)/$(PLATFORM_VERSION)/defs
defs_DATA =
# python
-if BUILD_GOBJECT
-pyexec_PYTHON = pygtk.py
-endif
pyexec_LTLIBRARIES =
noinst_PYTHON = ltihooks.py
# pygtk scripts
pkgpythondir = $(pyexecdir)/gtk-2.0
-if BUILD_GOBJECT
-pkgpython_PYTHON = dsextras.py
-endif
# pygtk extension modules
pkgpyexecdir = $(pyexecdir)/gtk-2.0
@@ -128,17 +111,5 @@ endif
&& cp gen-$*.c $*.c \
&& rm -f gen-$*.c
-if BUILD_GOBJECT
-# install pth file.
-install-data-local:
- $(mkinstalldirs) $(DESTDIR)$(pythondir)
- echo "gtk-$(PLATFORM_VERSION)" > $(DESTDIR)$(pyexecdir)/pygtk.pth
-install-exec-local:
- $(mkinstalldirs) $(DESTDIR)$(pyexecdir)
- echo "gtk-$(PLATFORM_VERSION)" > $(DESTDIR)$(pyexecdir)/pygtk.pth
-uninstall-local:
- rm -f $(DESTDIR)$(pythondir)/pygtk.pth $(DESTDIR)$(pyexecdir)/pygtk.pth
-endif
-
snap:
$(MAKE) dist distdir=$(PACKAGE)-SNAP-`date +"%Y%m%d"`