summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaul Pogonyshev <pogonyshev@gmx.net>2009-05-02 16:11:06 +0300
committerPaul Pogonyshev <pogonyshev@gmx.net>2009-05-02 16:11:06 +0300
commitdd2009d4e0e9fa9cd4ee8d76ec0e498e62a568b7 (patch)
treed13f1db39e0b7a3026d9f8193aaf194e90665c8d /Makefile.am
parent7a05b493a612da9f41a8f611ed56dcbcea7daa07 (diff)
downloadpygtk-dd2009d4e0e9fa9cd4ee8d76ec0e498e62a568b7.tar.gz
Remove 'ltihooks.py' as using deprecated Python module.
Remove the script and all related imports. All relevant Makefile's now create symbolic links for '.so' files from '.libs' to the level up, so that C helper modules are still importable in built, but not installed source tree. Same as in PyGObject. (Bug #565593.)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 1ed51965..24727273 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,10 +44,6 @@ pkgconfig_DATA += pygtk-$(PLATFORM_VERSION).pc
defsdir = $(pkgdatadir)/$(PLATFORM_VERSION)/defs
defs_DATA =
-# python
-pyexec_LTLIBRARIES =
-noinst_PYTHON = ltihooks.py
-
# pygtk scripts
pkgpythondir = $(pyexecdir)/gtk-2.0
@@ -141,3 +137,10 @@ doc-dist:
cp -r docs/cursors/* pygtk/cursors
tar cfz $(PACKAGE)-docs.tar.gz pygtk
rm -fr pygtk
+
+
+all: $(pkgpyexec_LTLIBRARIES:.la=.so)
+clean-local:
+ rm -f $(pkgpyexec_LTLIBRARIES:.la=.so)
+.la.so:
+ $(LN_S) .libs/$@ $@ || true