summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohan Dahlin <johan@src.gnome.org>2006-01-11 11:37:39 +0000
committerJohan Dahlin <johan@src.gnome.org>2006-01-11 11:37:39 +0000
commitdd5e6292cfae4ebdea62f2190964579fe79eb17b (patch)
tree386ec50acd09efc0686eea2a4e6db6db0e5a2819 /Makefile.am
parente9d5d7a71525f3247c913091e14c9e062ea372a8 (diff)
downloadpygtk-dd5e6292cfae4ebdea62f2190964579fe79eb17b.tar.gz
Only install pygtk.pth if we're building gobject.
* Makefile.am: Only install pygtk.pth if we're building gobject.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5496b9ff..f6c17e55 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -130,6 +130,7 @@ endif
&& cp gen-$*.c $*.c \
&& rm -f gen-$*.c
+if BUILD_GOBJECT
# install pth file.
install-data-local:
$(mkinstalldirs) $(DESTDIR)$(pythondir)
@@ -139,6 +140,7 @@ install-exec-local:
echo "gtk-$(PLATFORM_VERSION)" > $(DESTDIR)$(pyexecdir)/pygtk.pth
uninstall-local:
rm -f $(DESTDIR)$(pythondir)/pygtk.pth $(DESTDIR)$(pyexecdir)/pygtk.pth
+endif
snap:
$(MAKE) dist distdir=$(PACKAGE)-SNAP-`date +"%Y%m%d"`