summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Henstridge <james@daa.com.au>2001-09-28 23:43:47 +0000
committerJames Henstridge <jamesh@src.gnome.org>2001-09-28 23:43:47 +0000
commite0ef227e050134d9b0d9397865dd3c5053ba8d8f (patch)
tree1da46f929fc547582755dfc50cde016f04245299 /Makefile.am
parentc6a29df6dd65bbede61d2253637886789bebda51 (diff)
downloadpygtk-e0ef227e050134d9b0d9397865dd3c5053ba8d8f.tar.gz
use pyg_type_from_object instead. Based on patch from Elliot.
2001-09-29 James Henstridge <james@daa.com.au> * gtk/pygtktreemodel.c (pygtk_tree_model_get_column_type): use pyg_type_from_object instead. Based on patch from Elliot. * gtk/gtk.override (_wrap_gtk_selection_data__get_data): convert getter to a function to match codegen changes. * : merge in python22-branch (see changelog entries below).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 2 insertions, 9 deletions
diff --git a/Makefile.am b/Makefile.am
index 7112f40b..039246c8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,13 +5,7 @@ SUBDIRS = codegen gtk
INCLUDES = $(PYTHON_INCLUDES) $(GLIB_CFLAGS) $(PANGO_CFLAGS)
-pyexec_LTLIBRARIES = ExtensionClass.la gobjectmodule.la pangomodule.la
-
-ExtensionClass_la_LDFLAGS = -module -avoid-version \
- -export-symbols-regex initExtensionClass
-ExtensionClass_la_SOURCES = \
- ExtensionClass.h \
- ExtensionClass.c
+pyexec_LTLIBRARIES = gobjectmodule.la pangomodule.la
gobjectmodule_la_LDFLAGS = -module -avoid-version \
-export-symbols-regex initgobject
@@ -36,7 +30,7 @@ $(srcdir)/pango.c: $(srcdir)/pango.defs $(srcdir)/pango.override
&& cp gen-pango.c pango.c \
&& rm -f gen-pango.c
-pkginclude_HEADERS = pygobject.h ExtensionClass.h
+pkginclude_HEADERS = pygobject.h
noinst_PYTHON = ltihooks.py
@@ -53,7 +47,6 @@ EXTRA_DIST = \
pygtk.spec \
pygtk-2.0.pc.in \
MAPPING \
- ExtensionClass.stx \
pango.defs \
pango.override \
examples/gobject/signal.py \