summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Henstridge <james@daa.com.au>2002-08-24 14:25:23 +0000
committerJames Henstridge <jamesh@src.gnome.org>2002-08-24 14:25:23 +0000
commitf1368db68a3636c2b4d83dbbc66b1e2c0b1b7441 (patch)
tree7adec65f66c7cdf12710fea66461871bcf4c5fe1 /Makefile.am
parent247d4f488f913d50b7077b678125f66f7358a43a (diff)
downloadpygtk-f1368db68a3636c2b4d83dbbc66b1e2c0b1b7441.tar.gz
mingw32 patches from Cedric Gustin <cgustin@ibelgique.com>:
2002-08-24 James Henstridge <james@daa.com.au> mingw32 patches from Cedric Gustin <cgustin@ibelgique.com>: * gtk/gtk.override: ignore more socket/plug functions on win32. * gtk/gdk.override: gdk_pixmap_lookup is not implemented on win32. * gtk/Makefile.am (common_ldflags): and here. * pango.override (PyPangoAttribute_Type): initialise tp_alloc and tp_new in the init() function, rather than in the structure definition itself. * Makefile.am (common_ldflags): pass -no-undefined if we are on windows. * configure.in: turn on win32 DLL support, and add OS_WIN32 and PLATFORM_WIN32 conditionals for use in makefiles.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index d65dba2f..e9642485 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,15 +41,21 @@ pkgpyexec_LTLIBRARIES = \
pangomodule.la \
atkmodule.la
+if PLATFORM_WIN32
+common_ldflags = -module -avoid-version -no-undefined
+else
+common_ldflags = -module -avoid-version
+endif
+
# gobject module
-gobjectmodule_la_LDFLAGS = -module -avoid-version -export-symbols-regex initgobject
+gobjectmodule_la_LDFLAGS = $(common_ldflags) -export-symbols-regex initgobject
gobjectmodule_la_LIBADD = $(GLIB_LIBS)
gobjectmodule_la_SOURCES = \
pygobject.h pygobject-private.h \
gobjectmodule.c pygtype.c pygobject.c pygboxed.c
# pango module
-pangomodule_la_LDFLAGS = -module -avoid-version -export-symbols-regex initpango
+pangomodule_la_LDFLAGS = $(common_ldflags) -export-symbols-regex initpango
pangomodule_la_LIBADD = $(PANGO_LIBS)
pangomodule_la_SOURCES = pangomodule.c
nodist_pangomodule_la_SOURCES = pango.c
@@ -59,7 +65,7 @@ EXTRA_DIST += pango.override
defs_DATA += pango.defs pango-types.defs
# atk module
-atkmodule_la_LDFLAGS = -module -avoid-version -export-symbols-regex initatk
+atkmodule_la_LDFLAGS = $(common_ldflags) -export-symbols-regex initatk
atkmodule_la_LIBADD = $(ATK_LIBS)
atkmodule_la_SOURCES = atkmodule.c
nodist_atkmodule_la_SOURCES = atk.c