summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohan Dahlin <johan@src.gnome.org>2006-01-09 21:46:14 +0000
committerJohan Dahlin <johan@src.gnome.org>2006-01-09 21:46:14 +0000
commitf94212c61eb4771a4ca441cc2ba29a906cb48f36 (patch)
tree0c735c23e38f7e4783a8592229096d5ed2e58d97 /Makefile.am
parenta62703c49e315eb7b4e8f1646909aab25a2af86c (diff)
downloadpygtk-f94212c61eb4771a4ca441cc2ba29a906cb48f36.tar.gz
revert all changes from today
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 23 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 92b0ee57..a52c342d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,7 @@ if BUILD_GTK
GTK_SUBDIR = gtk
endif
-SUBDIRS = codegen . $(GTK_SUBDIR) docs examples tests
+SUBDIRS = codegen gobject . $(GTK_SUBDIR) docs examples tests
PLATFORM_VERSION = 2.0
@@ -13,6 +13,7 @@ EXTRA_DIST = \
ChangeLog.pre-2-0 \
ChangeLog.pre-2-6 \
config.h.win32 \
+ dsextras.py \
MANIFEST.in \
MAPPING \
pygtk.spec \
@@ -23,11 +24,11 @@ EXTRA_DIST = \
PKG-INFO.in \
setup.py \
THREADS
-INCLUDES = $(PYTHON_INCLUDES) $(GLIB_CFLAGS) $(PYGOBJECT_CFLAGS)
+INCLUDES = $(PYTHON_INCLUDES) $(GLIB_CFLAGS) -I$(top_srcdir)/gobject
# pkg-config files
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA =
+pkgconfig_DATA = pygobject-$(PLATFORM_VERSION).pc
if BUILD_GTK
pkgconfig_DATA += pygtk-$(PLATFORM_VERSION).pc
endif
@@ -37,10 +38,18 @@ defsdir = $(pkgdatadir)/$(PLATFORM_VERSION)/defs
defs_DATA =
# python
+pyexec_PYTHON = pygtk.py
pyexec_LTLIBRARIES =
-pkgpyexec_LTLIBRARIES =
noinst_PYTHON = ltihooks.py
+# pygtk scripts
+pkgpythondir = $(pyexecdir)/gtk-2.0
+pkgpython_PYTHON = dsextras.py
+
+# pygtk extension modules
+pkgpyexecdir = $(pyexecdir)/gtk-2.0
+pkgpyexec_LTLIBRARIES =
+
# linker flags
common_ldflags = -module -avoid-version
if PLATFORM_WIN32
@@ -103,5 +112,15 @@ endif
&& cp gen-$*.c $*.c \
&& rm -f gen-$*.c
+# install pth file.
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(pythondir)
+ echo "gtk-$(PLATFORM_VERSION)" > $(DESTDIR)$(pyexecdir)/pygtk.pth
+install-exec-local:
+ $(mkinstalldirs) $(DESTDIR)$(pyexecdir)
+ echo "gtk-$(PLATFORM_VERSION)" > $(DESTDIR)$(pyexecdir)/pygtk.pth
+uninstall-local:
+ rm -f $(DESTDIR)$(pythondir)/pygtk.pth $(DESTDIR)$(pyexecdir)/pygtk.pth
+
snap:
$(MAKE) dist distdir=$(PACKAGE)-SNAP-`date +"%Y%m%d"`