summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Pogonyshev <pogonyshev@gmx.net>2008-09-08 20:32:42 +0000
committerPaul Pogonyshev <paulp@src.gnome.org>2008-09-08 20:32:42 +0000
commitaec7f99584e3b0b294220fab44f98fc34f42b45f (patch)
tree6e2c08f379b8e8e5d79eaca4ae18fa6fdf578132 /configure.ac
parentf7cef33cba75cff1021572e3e26f155668098b97 (diff)
downloadpygtk-aec7f99584e3b0b294220fab44f98fc34f42b45f.tar.gz
Bug 550754 – need to import GIO types from PyGObject package
2008-09-08 Paul Pogonyshev <pogonyshev@gmx.net> Bug 550754 – need to import GIO types from PyGObject package * configure.ac: Determine if `gio-types.defs' is installed as part of PyGObject. * gtk/Makefile.am: Use it to register GIO types if installed. * gtk/gdk.override: Make gio.AppLaunchContext import conditional. Add conditional import of gio.Icon. * gtk/gtk.override: Make gio.MountOperation import conditional. Add conditional imports of gio.File and gio.Icon. svn path=/trunk/; revision=3037
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 58735fae..b957ce73 100644
--- a/configure.ac
+++ b/configure.ac
@@ -143,6 +143,22 @@ AC_SUBST(PYGOBJECT_INCLUDEDIR)
PYGOBJECT_DATADIR=`$PKG_CONFIG --variable=datadir pygobject-2.0`
AC_SUBST(PYGOBJECT_DATADIR)
+
+dnl PyGObject defs
+AC_SUBST(PYGOBJECT_DEFSDIR)
+PYGOBJECT_DEFSDIR=`$PKG_CONFIG --variable defsdir pygobject-2.0`
+
+AC_MSG_CHECKING([for gio-types.defs])
+if test -n "$PYGOBJECT_DEFSDIR" && test -e "$PYGOBJECT_DEFSDIR/gio-types.defs"; then
+ AM_CONDITIONAL(HAVE_GIO_TYPES_DEFS, true)
+ AC_MSG_RESULT($PYGOBJECT_DEFSDIR/gio-types.defs)
+else
+ AM_CONDITIONAL(HAVE_GIO_TYPES_DEFS, false)
+ AC_MSG_RESULT(no)
+fi
+
+
+dnl Documentation
PYGOBJECT_FIXXREF="$PYTHON `$PKG_CONFIG --variable=fixxref pygobject-2.0`"
AC_SUBST(PYGOBJECT_FIXXREF)