summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJames Henstridge <james@daa.com.au>1999-07-31 15:17:13 +0000
committerJames Henstridge <jamesh@src.gnome.org>1999-07-31 15:17:13 +0000
commitb353b664618a8e4a31453a22f680e18de7d36c77 (patch)
treeb77c3f4a1bde2665d75170af819e9e8089d1f9bb /configure.in
parent88b29cb44e8e5ca3ec2e7ae774166ebc43de82be (diff)
downloadpygtk-b353b664618a8e4a31453a22f680e18de7d36c77.tar.gz
put in Paul Fisher's enhancements to the threading code. It should now
1999-07-31 James Henstridge <james@daa.com.au> * gtkmodule.c: put in Paul Fisher's enhancements to the threading code. It should now work better with multiple threads calling GTK+ routines (remember to use threads_enter/threads_leave), and doesn't reintroduce the global interpreter lock problems that Duncan's original code worked around. * configure.in: added a check for the numpy header. * GdkImlib.py: added wrappers for the numpy routines. * gdkimlibmodule.c: added Travis Oliphant's Numeric python stuff to the imlib module.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1a682112..c1fa1ed5 100644
--- a/configure.in
+++ b/configure.in
@@ -16,6 +16,12 @@ AM_CONDITIONAL(BUILD_IMLIB, $build_imlib)
AM_PATH_GTKGL(build_gtkgl=true, build_gtkgl=false)
AM_CONDITIONAL(BUILD_GTKGL, $build_gtkgl)
+dnl checks to see if Numeric Python is installed.
+save_CPPFLAGS="$CPPFLAGS"
+CPPFLAGS="$CPPFLAGS $PYTHON_INCLUDES"
+AC_CHECK_HEADER(arrayobject.h, AC_DEFINE(HAVE_NUMPY))
+CPPFLAGS="$save_CPPFLAGS"
+
AC_OUTPUT(Makefile generate/Makefile pyglade/Makefile)