summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
authorGian Mario Tagliaretti <gianmt@src.gnome.org>2008-08-21 19:32:04 +0000
committerGian Mario Tagliaretti <gianmt@src.gnome.org>2008-08-21 19:32:04 +0000
commit0ba58e95fd712a3a9e4e46c935e68b637ccaa651 (patch)
tree31e6dcd93b79b0b676e3bd874e09b23da37200fb /docs/Makefile.am
parent07626b987e177b063696fe94b234ae5808da4459 (diff)
downloadpygtk-0ba58e95fd712a3a9e4e46c935e68b637ccaa651.tar.gz
Fix a problem with distcheck and avoid including .svn dir in the resulting tarball.
svn path=/trunk/; revision=3019
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
index 441ce65c..1f8279fb 100644
--- a/docs/Makefile.am
+++ b/docs/Makefile.am
@@ -581,20 +581,22 @@ HTML_FILES = \
html/unixprint-functions.html
-
CSS_FILES = $(PYGOBJECT_PYGDOCS)/style.css
TARGET_DIR = $(datadir)/gtk-doc/html/pygtk
CSSdir = $(TARGET_DIR)
EXTRA_DIST = \
- icons/*.png \
- cursors/*.png \
+ cursors icons \
$(HTML_FILES) \
$(XMLFILES) \
$(XSLFILES) \
$(FIX_XREF)
+dist-hook:
+ rm -rf `find $(distdir)/cursors -name .svn`
+ rm -rf `find $(distdir)/icons -name .svn`
+
install-data-local:
installfiles=`echo $(srcdir)/html/*`; \
if test "$$installfiles" = '$(srcdir)/html/*'; \
@@ -636,9 +638,9 @@ reference/builddate.xml:
@$(PYTHON) -c 'import datetime; print datetime.date.today()' > $@
-# Do not add a builddate.xml dependency here, because the generated html
-# documentation will be included in the tarball so xsltproc is not needed to
-# install the documentation. Adding a builddate.xml dependency will force
+# Do not add a builddate.xml dependency here, because the generated html
+# documentation will be included in the tarball so xsltproc is not needed to
+# install the documentation. Adding a builddate.xml dependency will force
# the documentation to be rebuilt when it doesn't need to be.
$(HTML_FILES): $(XMLFILES) $(XSLFILES)
@xsltproc --nonet --xinclude -o $(BUILDDIR)/html/ \