summaryrefslogtreecommitdiff
path: root/docs/Makefile.am
diff options
context:
space:
mode:
authorJohan Dahlin <johan@src.gnome.org>2006-08-04 21:03:41 +0000
committerJohan Dahlin <johan@src.gnome.org>2006-08-04 21:03:41 +0000
commit7277bfb11dc7037a003f3f95b7344cb0108527e2 (patch)
treefbe065effbda4b2333fd2cb2476d061f23c54e9b /docs/Makefile.am
parentbed02dcaaaf4c1803a32e3f607fa33bd71f4483e (diff)
downloadpygtk-7277bfb11dc7037a003f3f95b7344cb0108527e2.tar.gz
Clean up the build date/version mess I created. Now it's created during
* configure.in: * docs/Makefile.am: * docs/reference/entities.docbook.in: * docs/reference/pygtk2-ref.xml: Clean up the build date/version mess I created. Now it's created during configure time and properly included in the docbook files. Also make sure distcheck passes
Diffstat (limited to 'docs/Makefile.am')
-rw-r--r--docs/Makefile.am27
1 files changed, 10 insertions, 17 deletions
diff --git a/docs/Makefile.am b/docs/Makefile.am
index eef437d8..e390f243 100644
--- a/docs/Makefile.am
+++ b/docs/Makefile.am
@@ -1,7 +1,9 @@
+BUILDDIR = $(top_builddir)/docs
+
REF_VERSION = $(PYGTK_MAJOR_VERSION).$(PYGTK_MINOR_VERSION)
FULL_VERSION = $(REF_VERSION).$(PYGTK_MICRO_VERSION)
-FIX_XREF = ./fixxref.py
+FIX_XREF = $(srcdir)/fixxref.py
FIX_REF_INDEX_DIRS = -i $(datadir)/gtk-doc/html/pygobject
HTML_STYLE = $(PYGOBJECT_DATADIR)/pygobject/xsl/ref-html-style.xsl
PDF_STYLE = $(PYGOBJECT_DATADIR)/pygobject/xsl/pdf-style.xsl
@@ -575,39 +577,30 @@ HTML_DATA = \
BUILT_SOURCES = \
build_stamp \
- reference/builddate.xml \
- reference/version.xml \
$(HTML_DATA)
CLEANFILES = \
build_stamp \
- reference/builddate.xml \
- reference/version.xml \
pygtk-ref.* \
$(HTML_DATA)
EXTRA_DIST = \
$(XMLFILES) \
- $(XSLFILES)
+ $(XSLFILES) \
+ $(FIX_XREF)
REFERENCE_DEPS = \
- reference/version.xml \
reference \
$(XMLFILES) \
$(XSLFILES)
-reference/builddate.xml: $(REFERENCE_DEPS)
- @LANG=C $(PYTHON) -c 'import datetime; print datetime.date.today()' > $@
-
-reference/version.xml: $(top_srcdir)/config.h
- @echo $(FULL_VERSION) > $@
-
-build_stamp: $(REFERENCE_DEPS) reference/builddate.xml
- xsltproc --nonet --xinclude -o html/ \
+build_stamp: $(REFERENCE_DEPS)
+ xsltproc --nonet --xinclude -o $(BUILDDIR)/html/ \
+ --path $(BUILDDIR)/reference:$(srcdir)/reference \
--stringparam gtkdoc.bookname "pygtk" \
--stringparam gtkdoc.version ${REF_VERSION} \
- $(HTML_STYLE) reference/pygtk2-ref.xml
- python ${FIX_XREF} ${FIX_REF_INDEX_DIRS} html
+ $(HTML_STYLE) $(srcdir)/reference/pygtk2-ref.xml
+ python ${FIX_XREF} ${FIX_REF_INDEX_DIRS} $(BUILDDIR)/html
touch $@
pdf: $(REFERENCE_DEPS) reference/builddate.xml