summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorJames Henstridge <james@daa.com.au>2001-05-29 10:40:08 +0000
committerJames Henstridge <jamesh@src.gnome.org>2001-05-29 10:40:08 +0000
commit2dfc134d2a28b542a6157f36144569706bd38df8 (patch)
treedf51a5920156e963d6d20f96362a6e3c21dccd21 /gtk/Makefile.am
parent4a55f849dd5f72163be3e30f5ff6df3bba95c185 (diff)
downloadpygtk-2dfc134d2a28b542a6157f36144569706bd38df8.tar.gz
install the code generator
2001-05-29 James Henstridge <james@daa.com.au> * codegen/Makefile.am: install the code generator * gtk/Makefile.am: install the pygtk.h header * Makefile.am: install the pygobject.h header * gtk/gdk.defs, gtk/gtk.defs, gtk/gtk-types.c: changes to make things compile.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am21
1 files changed, 2 insertions, 19 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index d483016f..2522073c 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -2,18 +2,11 @@
INCLUDES = -I$(top_srcdir) $(PYTHON_INCLUDES) $(GTK_CFLAGS) \
$(GDK_IMLIB_CFLAGS) $(LIBGLADE_CFLAGS) $(GTKGL_CFLAGS) -Wall
-#if BUILD_LIBGLADE
-#libglademodule = libglademodule.la
-#endif
-#if BUILD_GTKGL
-#glmodule = glmodule.la
-#endif
-
pygtkdir = $(pythondir)/gtk
pygtk_PYTHON = __init__.py GTK.py GDK.py
pygtkexecdir = $(pyexecdir)/gtk
-pygtkexec_LTLIBRARIES = _gtkmodule.la #$(libglademodule) $(glmodule)
+pygtkexec_LTLIBRARIES = _gtkmodule.la
_gtkmodule_la_LDFLAGS = -module -avoid-version -export-symbols-regex init_gtk
_gtkmodule_la_LIBADD = $(GTK_LIBS)
@@ -27,17 +20,7 @@ _gtkmodule_la_SOURCES = \
pygtktreemodel.c \
gtk.c
-#libglademodule_la_LDFLAGS = -module -avoid-version
-#libglademodule_la_LIBADD = $(LIBGLADE_LIBS)
-#libglademodule_la_SOURCES = \
-# libglademodule.c \
-# libglade.c
-
-#glmodule_la_LDFLAGS = -module -avoid-version
-#glmodule_la_LIBADD = $(GTKGL_LIBS) $(GTK_LIBS)
-#glmodule_la_SOURCES = \
-# gtkglmodule.c \
-# gtkgl.c
+pkginclude_HEADERS = pygtk.h
# chmod hack here is because automake guys decided distdir should be
# read only for the next version :(