summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorPaul Pogonyshev <pogonyshev@gmx.net>2009-05-02 16:11:06 +0300
committerPaul Pogonyshev <pogonyshev@gmx.net>2009-05-02 16:11:06 +0300
commitdd2009d4e0e9fa9cd4ee8d76ec0e498e62a568b7 (patch)
treed13f1db39e0b7a3026d9f8193aaf194e90665c8d /gtk/Makefile.am
parent7a05b493a612da9f41a8f611ed56dcbcea7daa07 (diff)
downloadpygtk-dd2009d4e0e9fa9cd4ee8d76ec0e498e62a568b7.tar.gz
Remove 'ltihooks.py' as using deprecated Python module.
Remove the script and all related imports. All relevant Makefile's now create symbolic links for '.so' files from '.libs' to the level up, so that C helper modules are still importable in built, but not installed source tree. Same as in PyGObject. (Bug #565593.)
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 20212202..b9ec8f39 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -195,7 +195,7 @@ CLEANFILES += \
gtkunixprint.c \
gtkunixprint.defs \
gtkunixprint-types.defs
-
+
EXTRA_DIST += \
$(GTKUNIXPRINT_DEFS) \
@@ -248,3 +248,9 @@ endif
gtk-types.c:
@:
+
+all: $(pygtkexec_LTLIBRARIES:.la=.so) $(pkgpyexec_LTLIBRARIES:.la=.so)
+clean-local:
+ rm -f $(pygtkexec_LTLIBRARIES:.la=.so) $(pkgpyexec_LTLIBRARIES:.la=.so)
+.la.so:
+ $(LN_S) .libs/$@ $@ || true