summaryrefslogtreecommitdiff
path: root/pygtk.spec
diff options
context:
space:
mode:
authorJames Henstridge <jamesh@src.gnome.org>1998-12-06 10:08:08 +0000
committerJames Henstridge <jamesh@src.gnome.org>1998-12-06 10:08:08 +0000
commit997c302f261c2000d057bdaa989ec12ca00d7fa9 (patch)
tree32fd0d0cf70a0d804df0765d610518db281801a0 /pygtk.spec
downloadpygtk-997c302f261c2000d057bdaa989ec12ca00d7fa9.tar.gz
Initial revision
Diffstat (limited to 'pygtk.spec')
-rw-r--r--pygtk.spec45
1 files changed, 45 insertions, 0 deletions
diff --git a/pygtk.spec b/pygtk.spec
new file mode 100644
index 00000000..a146b9ab
--- /dev/null
+++ b/pygtk.spec
@@ -0,0 +1,45 @@
+%define py_prefix /usr
+# py_ver should only be 3 characters (1.5.1 == 1.5)
+%define py_ver 1.5
+%define ver 0.5.6
+
+Summary: Python bindings for the GTK+ widget set.
+Name: pygtk
+Version: %ver
+Release: 1
+Copyright: GPL
+Group: X11/Libraries
+Source: ftp://ftp.daa.com.au/pub/james/python/pygtk-%{ver}.tar.gz
+BuildRoot: /tmp/pygtk-root
+Packager: James Henstridge <james@daa.com.au>
+Requires: gtk+ imlib python
+
+%description
+PyGTK is an extension module for python that gives you access to the GTK+
+widget set. Just about anything you can write in C with GTK+ you can write
+in python with PyGTK (within reason), but with all of python's benefits.
+
+%prep
+%setup
+./configure
+
+%build
+make
+
+%install
+rm -rf $RPM_BUILD_ROOT
+make DESTDIR=$RPM_BUILD_ROOT install
+
+%files
+%{py_prefix}/lib/python%{py_ver}/site-packages/gtk.py*
+%{py_prefix}/lib/python%{py_ver}/site-packages/Gtkinter.py*
+%{py_prefix}/lib/python%{py_ver}/site-packages/GtkExtra.py*
+%{py_prefix}/lib/python%{py_ver}/site-packages/GTK.py*
+%{py_prefix}/lib/python%{py_ver}/site-packages/GDK.py*
+%{py_prefix}/lib/python%{py_ver}/site-packages/GdkImlib.py*
+%{py_prefix}/lib/python%{py_ver}/site-packages/pyglade/*.py*
+
+%{py_prefix}/lib/python%{py_ver}/site-packages/_gtkmodule.so
+%{py_prefix}/lib/python%{py_ver}/site-packages/_gdkimlibmodule.so
+
+%doc AUTHORS NEWS README ChangeLog description.py