summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNaofumi Yasufuku <naofumi@yasufuku.net>2003-07-02 13:39:44 +0000
committerJames Henstridge <jamesh@src.gnome.org>2003-07-02 13:39:44 +0000
commit878262ed46d94a317d19397cd72ca6d28e4d624f (patch)
tree71d4e25f5211a6c86414316684a1b4ce826390d1 /setup.py
parent279b8380d131fc1ab178239f87cab73d6c7aa90c (diff)
downloadpygtk-878262ed46d94a317d19397cd72ca6d28e4d624f.tar.gz
Bug #110619:
2003-05-03 Naofumi Yasufuku <naofumi@yasufuku.net> Bug #110619: * dsextras.py (InstallLib.prepare): Fixed self.prefix initialization for win32. (BuildExt.init_extra_compile_args, BuildExt.build_extensions) (BuildExt.build_extension): On win32, add MinGW GCC option for MSVC compatible struct packing (gcc2: -fnative-struct, gcc3: -mms-bitfields). (BuildExt.modify_compiler, BuildExt.build_extensions): On win32, remove '-static' linker option to prevent MinGW ld from trying to link with MSVC import libraries. * setup.py: Changed list_files('codegen/*.py') to list_files(os.path.join('codegen', '*.py')) for win32. Fixed pygtk.h installation directory. 2003-07-02 James Henstridge <james@daa.com.au> * dsextras.py (pkgc_version_check): remove "self.", fixing bug 111002 (pointed out by Seth Nickell).
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 636d8b8c..0081e825 100755
--- a/setup.py
+++ b/setup.py
@@ -186,7 +186,7 @@ if not have_pkgconfig():
if gobject.can_build():
ext_modules.append(gobject)
data_files.append((INCLUDE_DIR, ('pygobject.h',)))
- data_files.append((CODEGEN_DIR, list_files('codegen/*.py')))
+ data_files.append((CODEGEN_DIR, list_files(os.path.join('codegen', '*.py'))))
else:
print
print 'ERROR: Nothing to do, gobject could not be found and is essential.'
@@ -205,7 +205,7 @@ if gtk.can_build():
print ('* Numeric module could not be found, '
'will build without Numeric support.')
ext_modules.append(gtk)
- data_files.append((INCLUDE_DIR, ('gtk/pygtk.h',)))
+ data_files.append((os.path.join(INCLUDE_DIR, 'pygtk'), ('gtk/pygtk.h',)))
data_files.append((DEFS_DIR, ('gtk/gdk.defs', 'gtk/gdk-types.defs',
'gtk/gtk.defs', 'gtk/gtk-types.defs',
'gtk/gtk-extrafuncs.defs')))