summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDieter Verfaillie <dieterv@optionexplicit.be>2010-11-03 10:47:00 +0100
committerDieter Verfaillie <dieterv@optionexplicit.be>2010-11-03 10:47:00 +0100
commit8bc2463cca8aea8cbd69895e37abb11cd616778b (patch)
treec9336825bfbcb519abbfd18c828787a800cd74cc /setup.py
parent175b6ba7c8e446632541debfb7af3942bd1b60ec (diff)
downloadpygtk-8bc2463cca8aea8cbd69895e37abb11cd616778b.tar.gz
setup.py: rearrange imports
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py20
1 files changed, 15 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index b86b3a97..64132120 100755
--- a/setup.py
+++ b/setup.py
@@ -1,14 +1,24 @@
#!/usr/bin/env python
+# -*- coding: utf-8 -*-
#
# setup.py - distutils configuration for pygtk
-#
-"""Python Bindings for the GTK Widget Set."""
-from distutils.command.build import build
-from distutils.core import setup
-import glob
+
+'''Python Bindings for the GTK+ Widget Set.
+
+PyGTK is a set of bindings for the GTK+ widget set. It provides an object
+oriented interface that is slightly higher level than the C one. It
+automatically does all the type casting and reference counting that you
+would have to do normally with the C API. You can find out more on the
+official homepage, http://www.pygtk.org/'''
+
+
import os
import sys
+import glob
+
+from distutils.command.build import build
+from distutils.core import setup
from dsextras import get_m4_define, getoutput, have_pkgconfig, \
pkgc_version_check, getoutput, \