summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohn Ehresman <jpe@wingware.com>2006-04-18 21:47:23 +0000
committerJohn Ehresman <jpe@src.gnome.org>2006-04-18 21:47:23 +0000
commit8e010bdff37ed5566ba6f80c4166ae635611567c (patch)
treed6f43c28486f8679f314a93cfe42c58d2ee99e2e /setup.py
parent5ab25b3ac21490b0f33108503e933200fa8ed0d3 (diff)
downloadpygtk-8e010bdff37ed5566ba6f80c4166ae635611567c.tar.gz
Remove support for building / installing gobject, pygtk.py, and
2006-04-18 John Ehresman <jpe@wingware.com> * setup.py: Remove support for building / installing gobject, pygtk.py, and dsextras.py
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py40
1 files changed, 1 insertions, 39 deletions
diff --git a/setup.py b/setup.py
index 391e8a77..843cf6fc 100755
--- a/setup.py
+++ b/setup.py
@@ -58,7 +58,7 @@ PYCAIRO_REQUIRED = get_m4_define('pycairo_required_version')
PYGTK_SUFFIX = '2.0'
PYGTK_SUFFIX_LONG = 'gtk-' + PYGTK_SUFFIX
-GLOBAL_INC += ['.', 'gtk', 'gobject']
+GLOBAL_INC += ['.', 'gtk']
GLOBAL_MACROS += [('PYGTK_MAJOR_VERSION', MAJOR_VERSION),
('PYGTK_MINOR_VERSION', MINOR_VERSION),
('PYGTK_MICRO_VERSION', MICRO_VERSION)]
@@ -79,7 +79,6 @@ class PyGtkInstallLib(InstallLib):
# Install pygtk.pth, pygtk.py[c] and templates
self.install_pth()
- self.install_pygtk()
# Modify the base installation dir
install_dir = os.path.join(self.install_dir, PYGTK_SUFFIX_LONG)
@@ -95,14 +94,6 @@ class PyGtkInstallLib(InstallLib):
self.local_outputs.append(file)
self.local_inputs.append('pygtk.pth')
- def install_pygtk(self):
- """install pygtk.py in the right place."""
- self.copy_file('pygtk.py', self.install_dir)
- pygtk = os.path.join(self.install_dir, 'pygtk.py')
- self.byte_compile([pygtk])
- self.local_outputs.append(pygtk)
- self.local_inputs.append('pygtk.py')
-
class PyGtkInstallData(InstallData):
def run(self):
self.add_template_option('VERSION', VERSION)
@@ -120,32 +111,12 @@ class PyGtkInstallData(InstallData):
self.install_template('pygtk-2.0.pc.in',
os.path.join(self.install_dir,
'lib','pkgconfig'))
- self.install_template('pygobject-2.0.pc.in',
- os.path.join(self.install_dir,
- 'lib', 'pkgconfig'))
class PyGtkBuild(build):
enable_threading = 1
PyGtkBuild.user_options.append(('enable-threading', None,
'enable threading support'))
-# GObject
-gobject = PkgConfigExtension(name='gobject', pkc_name='gobject-2.0',
- pkc_version=GOBJECT_REQUIRED,
- sources=['gobject/gobjectmodule.c',
- 'gobject/pygboxed.c',
- 'gobject/pygenum.c',
- 'gobject/pygflags.c',
- 'gobject/pygobject.c',
- 'gobject/pygmaincontext.c',
- 'gobject/pygmainloop.c',
- 'gobject/pygparamspec.c',
- 'gobject/pygpointer.c',
- 'gobject/pygtype.c',
- 'gobject/pygsource.c',
- 'gobject/pygiochannel.c',
- ])
-
# Atk
atk = TemplateExtension(name='atk', pkc_name='atk',
pkc_version=ATK_REQUIRED,
@@ -215,20 +186,11 @@ libglade = TemplateExtension(name='libglade', pkc_name='libglade-2.0',
data_files = []
ext_modules = []
py_modules = []
-py_modules.append('dsextras')
if not have_pkgconfig():
print "Error, could not find pkg-config"
raise SystemExit
-if gobject.can_build():
- ext_modules.append(gobject)
- data_files.append((INCLUDE_DIR, ('gobject/pygobject.h',)))
- data_files.append((CODEGEN_DIR, list_files(os.path.join('codegen', '*.py'))))
-else:
- print
- print 'ERROR: Nothing to do, gobject could not be found and is essential.'
- raise SystemExit
if atk.can_build():
ext_modules.append(atk)
data_files.append((DEFS_DIR, ('atk.defs', 'atk-types.defs')))