summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDieter Verfaillie <dieterv@optionexplicit.be>2010-11-04 10:29:25 +0100
committerDieter Verfaillie <dieterv@optionexplicit.be>2010-11-04 10:29:25 +0100
commit9c529bfae84f5318d1184d1050417f5482986044 (patch)
tree041f76ca604b45a0ae97edcca79fb1f15d9c71f2 /setup.py
parent4aad94e9d68375e62d385ffce1f062763710cf37 (diff)
downloadpygtk-9c529bfae84f5318d1184d1050417f5482986044.tar.gz
setup.py: don't install pygtk.pth here as we depend on pygobject at runtime which is already resposible for the installation of pygtk.pth and pygtk.py[c]
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py11
1 files changed, 0 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index be8c1375..3d2266b0 100755
--- a/setup.py
+++ b/setup.py
@@ -86,9 +86,6 @@ HTML_DIR = os.path.join('share', 'gtk-doc', 'html', 'pygtk')
class PyGtkInstallLib(InstallLib):
def run(self):
- # Install pygtk.pth, pygtk.py[c] and templates
- self.install_pth()
-
# Modify the base installation dir
install_dir = os.path.join(self.install_dir, PYGTK_SUFFIX_LONG)
self.set_install_dir(install_dir)
@@ -98,14 +95,6 @@ class PyGtkInstallLib(InstallLib):
InstallLib.run(self)
- def install_pth(self):
- '''Write the pygtk.pth file'''
- file = os.path.join(self.install_dir, 'pygtk.pth')
- self.mkpath(self.install_dir)
- open(file, 'w').write(PYGTK_SUFFIX_LONG)
- self.local_outputs.append(file)
- self.local_inputs.append('pygtk.pth')
-
def copy_test(self, srcfile, dstfile=None):
if dstfile is None:
dstfile = os.path.join(self.test_dir, srcfile)