summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohan Dahlin <johan@src.gnome.org>2005-08-24 18:25:04 +0000
committerJohan Dahlin <johan@src.gnome.org>2005-08-24 18:25:04 +0000
commitdf7b5001af87ef80f82e1806a32769936c900425 (patch)
tree193fdee5e35dcabf6f1a0f9d5fafb44dd4b870db /setup.py
parent028e134a8cc2ccaf1729a72518744761078b5820 (diff)
downloadpygtk-df7b5001af87ef80f82e1806a32769936c900425.tar.gz
Enable threading by default, do not always link against libgthread
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 5 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 3efaf93c..55f4277f 100755
--- a/setup.py
+++ b/setup.py
@@ -216,7 +216,6 @@ if not have_pkgconfig():
raise SystemExit
if gobject.can_build():
- gobject.libraries.append('gthread-2.0')
ext_modules.append(gobject)
data_files.append((INCLUDE_DIR, ('gobject/pygobject.h',)))
data_files.append((CODEGEN_DIR, list_files(os.path.join('codegen', '*.py'))))
@@ -249,12 +248,12 @@ if gtk.can_build():
'gtk/gtk.defs', 'gtk/gtk-types.defs',
'gtk/gtk-extrafuncs.defs')))
py_modules += ['gtk.compat', 'gtk.keysyms']
+
if libglade.can_build():
ext_modules.append(libglade)
data_files.append((DEFS_DIR, ('gtk/libglade.defs',)))
-if '--enable-threading' in sys.argv:
- sys.argv.remove('--enable-threading')
+if not '--disable-threading' in sys.argv:
try:
import thread
except ImportError:
@@ -268,6 +267,9 @@ if '--enable-threading' in sys.argv:
module.extra_link_args += raw.split()
raw = getoutput('pkg-config --cflags-only-I %s' % name)
module.extra_compile_args.append(raw)
+else:
+ sys.argv.remove('--disable-threading')
+
doclines = __doc__.split("\n")
options = {"bdist_wininst": {"install_script": "pygtk_postinstall.py"}}