summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohan Dahlin <johan@src.gnome.org>2004-08-10 20:22:19 +0000
committerJohan Dahlin <johan@src.gnome.org>2004-08-10 20:22:19 +0000
commite419b14a8279429411015772a77eefcc087df58d (patch)
tree6c4629c2f689003d6178081b41e42cffd3490deb /setup.py
parent783ec077352a4a89c53bf7e4c46ed8c5dcbf92e6 (diff)
downloadpygtk-e419b14a8279429411015772a77eefcc087df58d.tar.gz
Disable distutils for Linux and update README
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index b2767fcd..b04ef1de 100755
--- a/setup.py
+++ b/setup.py
@@ -24,6 +24,9 @@ from dsextras import getoutput, have_pkgconfig, list_files, \
GLOBAL_INC, GLOBAL_MACROS, InstallLib, BuildExt, \
PkgConfigExtension, Template, TemplateExtension
+if sys.platform != "win32":
+ raise SystemExit, "Building PyGTK through distutils is not supported on Linux, please use configure to build PyGTK."
+
MAJOR_VERSION = 2
MINOR_VERSION = 3
MICRO_VERSION = 97