summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDieter Verfaillie <dieterv@optionexplicit.be>2010-11-03 10:59:37 +0100
committerDieter Verfaillie <dieterv@optionexplicit.be>2010-11-03 10:59:37 +0100
commite46b1bd5a931aa78421bb9063dcf971b0dc55e2f (patch)
tree4909cbc2d309bfe57d01f57f7a08b9d44a9c45da /setup.py
parent9d82336cc4cf4318519ddaefad83ec6ec50b40f9 (diff)
downloadpygtk-e46b1bd5a931aa78421bb9063dcf971b0dc55e2f.tar.gz
setup.py: add NUMPY_INCLUDE dir to gtk.include_dirs
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 7811261d..d32e65eb 100755
--- a/setup.py
+++ b/setup.py
@@ -296,6 +296,9 @@ if gtk.can_build():
import numpy
numpy # pyflakes
GLOBAL_MACROS.append(('HAVE_NUMPY', 1))
+ NUMPY_INCLUDE = os.path.join(os.path.dirname(numpy.__file__),
+ 'core', 'include')
+ gtk.include_dirs.append(NUMPY_INCLUDE)
except ImportError:
print '* numpy module could not be found, will build without numpy support.'