summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJohan Dahlin <johan@src.gnome.org>2004-07-19 10:14:25 +0000
committerJohan Dahlin <johan@src.gnome.org>2004-07-19 10:14:25 +0000
commitb3de7e2666bd30cc9c3b54e21e6982636a2417f2 (patch)
treea383b84e7510db444203f704cda0d4dff82976c8 /tests/Makefile.am
parente3f97359c6d0a7a2cd45b305d9a2396cf4a5a606 (diff)
downloadpygtk-b3de7e2666bd30cc9c3b54e21e6982636a2417f2.tar.gz
Remove, out of date since 0.6.x!
* description.py: Remove, out of date since 0.6.x! * tests/Makefile.am, tests/common.py: Make distcheck pass
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index c592b968..d7ef6018 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -3,8 +3,12 @@ tests = \
enum.py \
signal.py
-check-local:
- @PYTHONPATH=$(top_builddir):$(top_builddir)/.libs:$(top_builddir)/gtk/.libs $(PYTHON) $(srcdir)/runtests.py
- @rm -fr *.pyc
+PYTHONPATH = $(top_builddir):$(top_builddir)/gobject:$(top_srcdir):$(top_srcdir)/gtk
-EXTRA_DIST = $(tests) runtests.py
+check-local: $(top_srcdir)/gtk/__init__.py
+ @if ! test -e $(top_builddir)/gtk/__init__.py; then cp $(top_srcdir)/gtk/__init__.py $(top_builddir)/gtk/__init__.py; fi
+ @PYTHONPATH=$(PYTHONPATH) $(PYTHON) $(srcdir)/runtests.py
+ @if test "$(top_builddir)" != "$(top_srcdir)"; then rm -f $(top_builddir)/gtk/__init__.py*; fi
+ @rm -fr *.pyc
+
+EXTRA_DIST = $(tests) common.py runtests.py