summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 1ed51965..24727273 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,10 +44,6 @@ pkgconfig_DATA += pygtk-$(PLATFORM_VERSION).pc
defsdir = $(pkgdatadir)/$(PLATFORM_VERSION)/defs
defs_DATA =
-# python
-pyexec_LTLIBRARIES =
-noinst_PYTHON = ltihooks.py
-
# pygtk scripts
pkgpythondir = $(pyexecdir)/gtk-2.0
@@ -141,3 +137,10 @@ doc-dist:
cp -r docs/cursors/* pygtk/cursors
tar cfz $(PACKAGE)-docs.tar.gz pygtk
rm -fr pygtk
+
+
+all: $(pkgpyexec_LTLIBRARIES:.la=.so)
+clean-local:
+ rm -f $(pkgpyexec_LTLIBRARIES:.la=.so)
+.la.so:
+ $(LN_S) .libs/$@ $@ || true