summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 7811261d..d32e65eb 100755
--- a/setup.py
+++ b/setup.py
@@ -296,6 +296,9 @@ if gtk.can_build():
import numpy
numpy # pyflakes
GLOBAL_MACROS.append(('HAVE_NUMPY', 1))
+ NUMPY_INCLUDE = os.path.join(os.path.dirname(numpy.__file__),
+ 'core', 'include')
+ gtk.include_dirs.append(NUMPY_INCLUDE)
except ImportError:
print '* numpy module could not be found, will build without numpy support.'