summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSebastien Martini <seb@dbzteam.org>2009-11-06 01:05:18 +0100
committerSebastien Martini <seb@dbzteam.org>2009-11-06 01:05:18 +0100
commita307369bed619929c3bb5e97a557054947e246e2 (patch)
treed24423271f8f164961a410d63894c7825cdf957c /setup.py
parent6141698fa66aab032f83fa367b735975061504a2 (diff)
downloadpyinotify-a307369bed619929c3bb5e97a557054947e246e2.tar.gz
Modified Pyinotify's hierarchy in order to support differents version
for Python2 and for Python3.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py46
1 files changed, 0 insertions, 46 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100755
index ab6a8b2..0000000
--- a/setup.py
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/usr/bin/env python
-
-# check Python's version
-import sys
-if sys.version < '2.4':
- sys.stderr.write('This module requires Python 2.4 or later.\n')
- sys.exit(1)
-
-# import statements
-from distutils.core import setup, Extension
-from distutils.util import get_platform
-
-# debug
-DISTUTILS_DEBUG = True
-
-# get platform
-platform = get_platform()
-
-# check linux platform
-if not platform.startswith('linux'):
- raise Exception, "inotify is not available under %s" % platform
-
-classif=[
- 'Environment :: Console',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: GNU General Public License (GPL)',
- 'Natural Language :: English',
- 'Operating System :: POSIX :: Linux',
- 'Programming Language :: Python',
- 'Topic :: Software Development :: Libraries',
- 'Topic :: System :: Monitoring'
- ]
-
-setup(
- name='pyinotify',
- version='0.8.8',
- description='Linux filesystem events monitoring',
- author='Sebastien Martini',
- author_email='sebastien.martini@gmail.com',
- license='GPLv2+',
- platforms='Linux',
- classifiers=classif,
- url='http://trac.dbzteam.org/pyinotify',
- download_url='http://seb.dbzteam.org/pub/pyinotify/releases/pyinotify-0.8.8.tar.gz',
- py_modules=['pyinotify'],
- )