summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJean-Paul Calderone <exarkun@twistedmatrix.com>2014-03-03 09:12:06 -0500
committerJean-Paul Calderone <exarkun@twistedmatrix.com>2014-03-03 09:12:06 -0500
commit1674313f1d4bb3361beb4ee98328198c29575f58 (patch)
tree3d47f33b203d46e195d71e8983d79cd1698a6d59 /setup.py
parent3078273bda4bc5f5448a5d93ca62cd672d76c9c0 (diff)
downloadpyopenssl-git-1674313f1d4bb3361beb4ee98328198c29575f58.tar.gz
add Python :: 2 and some comments referring to reasons to include Python :: 3 here
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py14
1 files changed, 13 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f22d989..058ad7b 100755
--- a/setup.py
+++ b/setup.py
@@ -49,11 +49,23 @@ High-level wrapper around a subset of the OpenSSL library, includes
'Operating System :: MacOS :: MacOS X',
'Operating System :: Microsoft :: Windows',
'Operating System :: POSIX',
+
+ # General classifiers to indicate "this project supports Python 2" and
+ # "this project supports Python 3".
+ 'Programming Language :: Python :: 2',
+ # In particular, this makes pyOpenSSL show up on
+ # https://pypi.python.org/pypi?:action=browse&c=533&show=all and is in
+ # accordance with
+ # http://docs.python.org/2/howto/pyporting.html#universal-bits-of-advice
+ 'Programming Language :: Python :: 3',
+
+ # More specific classifiers to indicate more precisely which versions
+ # of those languages the project supports.
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3',
+
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Security :: Cryptography',