summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJean-Paul Calderone <exarkun@divmod.com>2009-02-08 16:54:28 -0500
committerJean-Paul Calderone <exarkun@divmod.com>2009-02-08 16:54:28 -0500
commit2210f79928e87c40f972dde3857bc995c899a6e6 (patch)
tree0047d2d044d5c7058f7fbd0bbc6ef62736e62582 /setup.py
parent5a1bf38c3645c891591e129c115e1dbd936a2bc6 (diff)
downloadpyopenssl-2210f79928e87c40f972dde3857bc995c899a6e6.tar.gz
Work around a gross distutils bug - forward slashes cause the path to get mangled incorrectly
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 6eb9508..b4e858a 100755
--- a/setup.py
+++ b/setup.py
@@ -44,9 +44,10 @@ LibraryDirs = None
if os.name == 'nt' or sys.platform == 'win32':
Libraries = ['eay32', 'Ws2_32']
# Try to find it...
- for path in ["C:/Python25/libs/", "C:/Python26/libs/", "C:/OpenSSL/lib/MinGW/"]:
- if os.path.exists(os.path.join(path, "ssleay32.a")):
- ExtraObjects = [os.path.join(path, "ssleay32.a")]
+ for path in ["C:\\Python25\\libs\\", "C:\\Python26\\libs\\", "C:\\OpenSSL\\lib\\MinGW\\"]:
+ ssleay32 = os.path.join(path, "ssleay32.a")
+ if os.path.exists(ssleay32):
+ ExtraObjects = [ssleay32]
break
else:
raise SystemExit("Cannot find ssleay32.a, aborting")