summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authortavis_rudd <tavis_rudd>2001-08-03 19:20:50 +0000
committertavis_rudd <tavis_rudd>2001-08-03 19:20:50 +0000
commitf7eee3bd60ee808b3535952e9aef51c714c48f28 (patch)
treea7a6402930777a8a9371ae4adc9a73143cbfbf93 /setup.py
parent700c7729bbe0871c437033360f8968acf3e9face (diff)
downloadpython-cheetah-f7eee3bd60ee808b3535952e9aef51c714c48f28.tar.gz
made changes to Template.py, CodeGenerator.py, PlaceholderProcessor.py,
and TagProcessor.py to enable customization of the placeholderStartToken (default $). + updated so docs
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py12
1 files changed, 7 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index a9d4a1f..07fbbdb 100755
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,5 @@
#!/usr/bin/env python
-# $Id: setup.py,v 1.5 2001/08/02 05:17:15 tavis_rudd Exp $
+# $Id: setup.py,v 1.6 2001/08/03 19:20:50 tavis_rudd Exp $
"""A setup module for the Cheetah package, based on the disutils module
Meta-Data
@@ -7,18 +7,18 @@ Meta-Data
Author: Tavis Rudd <tavis@calrudd.com>
License: This software is released for unlimited distribution under the
terms of the Python license.
-Version: $Revision: 1.5 $
+Version: $Revision: 1.6 $
Start Date: 2001/03/30
-Last Revision Date: $Date: 2001/08/02 05:17:15 $
+Last Revision Date: $Date: 2001/08/03 19:20:50 $
"""
__author__ = "Tavis Rudd <tavis@calrudd.com>"
-__version__ = "$Revision: 1.5 $"[11:-2]
+__version__ = "$Revision: 1.6 $"[11:-2]
##################################################
## DEPENDENCIES ##
-from distutils.core import setup
+from distutils.core import setup, Extension
from distutils.command.sdist import sdist
import os
@@ -94,6 +94,8 @@ if __name__ == '__main__':
packages = packages,
package_dir = {'Cheetah':'src'},
+ #ext_modules=[Extension("Cheetah/_namemapper", ["src/_namemapper.c"])],
+
scripts = ['bin/cheetah-compile',],
cmdclass = { 'sdist_docs' : sdist_docs },