summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNed Batchelder <ned@nedbatchelder.com>2012-03-20 09:43:29 -0400
committerNed Batchelder <ned@nedbatchelder.com>2012-03-20 09:43:29 -0400
commitd0ee1989ec56dc039ad880c1d554e66dd4caddd8 (patch)
treeb85a3b949dd1dac766695f15677959e67e28f48c /setup.py
parentb7e427abd66c45b094e9159b669490d36c0fb5bc (diff)
downloadpython-coveragepy-git-d0ee1989ec56dc039ad880c1d554e66dd4caddd8.tar.gz
All the tests pass under PyPy: sys has a bogus __file__, Unicode is 4-byte, and pypy inserts an extra stack frame into tracebacks.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 71c43421..bad1c048 100644
--- a/setup.py
+++ b/setup.py
@@ -110,7 +110,7 @@ if sys.platform.startswith('java'):
# Jython can't compile C extensions
compile_extension = False
-if hasattr(sys, "pypy_version_info"):
+if '__pypy__' in sys.builtin_module_names:
# Pypy can't compile C extensions
compile_extension = False