summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNed Batchelder <ned@nedbatchelder.com>2009-09-27 11:08:45 -0400
committerNed Batchelder <ned@nedbatchelder.com>2009-09-27 11:08:45 -0400
commit189b4f38e6831b08cc7441d0157b9bcb8b2ba4f8 (patch)
tree7e9344bc740e770f1feafe16bd36d45bd6bd9863 /setup.py
parentd48260b18674fe04931177f5c2f43ddfd0a96383 (diff)
downloadpython-coveragepy-189b4f38e6831b08cc7441d0157b9bcb8b2ba4f8.tar.gz
Tweaks to the package description.coverage-3.1b1
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 9 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 2317084..7a296d6 100644
--- a/setup.py
+++ b/setup.py
@@ -2,12 +2,14 @@
"""Code coverage measurement for Python
-Coverage measures code coverage, typically during test execution. It uses the
-code analysis tools and tracing hooks provided in the Python standard library
-to determine which lines are executable, and which have been executed.
+Coverage.py measures code coverage, typically during test execution. It uses the
+code analysis tools and tracing hooks provided in the Python standard library to
+determine which lines are executable, and which have been executed.
-Code repository and issue tracker are at
-`bitbucket.org <http://bitbucket.org/ned/coveragepy>`_.
+Coverage.py runs on Pythons 2.3 through 3.1.
+
+Documentation is at `nedbatchelder.com <%s>`_. Code repository and issue
+tracker are at `bitbucket.org <http://bitbucket.org/ned/coveragepy>`_.
"""
@@ -59,7 +61,7 @@ else:
from coverage import __url__, __version__
-doclines = __doc__.split('\n')
+doclines = (__doc__ % __url__).split('\n')
classifier_list = [c for c in classifiers.split("\n") if c]
@@ -101,4 +103,4 @@ setup(
url = __url__,
**more_setup_args
-)
+ )