summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNed Batchelder <ned@nedbatchelder.com>2015-08-01 08:20:42 -0400
committerNed Batchelder <ned@nedbatchelder.com>2015-08-01 08:20:42 -0400
commit18b20125a00af467dfab67485c9c3aabdab17747 (patch)
tree434900cac2684aff9010486cea3cae8d6abe6dd4 /setup.py
parent23d08e5109d5a8bd2210ef1404da0f5c1314001c (diff)
downloadpython-coveragepy-18b20125a00af467dfab67485c9c3aabdab17747.tar.gz
Move tracer.c into a subdirectory, so we can split it up.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 9c35f31..8646168 100644
--- a/setup.py
+++ b/setup.py
@@ -175,7 +175,12 @@ if '__pypy__' in sys.builtin_module_names:
if compile_extension:
setup_args.update(dict(
ext_modules = [
- Extension("coverage.tracer", sources=["coverage/tracer.c"])
+ Extension(
+ "coverage.tracer",
+ sources=[
+ "coverage/ctracer/tracer.c",
+ ]
+ )
],
cmdclass = {
'build_ext': ve_build_ext,