summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNed Batchelder <ned@nedbatchelder.com>2012-12-23 17:55:48 -0500
committerNed Batchelder <ned@nedbatchelder.com>2012-12-23 17:55:48 -0500
commit831f7010f0cd1b20f054d3b90dae24445e36cb20 (patch)
tree2dcae1b3ecb66ca2c4921d1dc5fdeb8d96697ea1 /setup.py
parent1a6010d34f65c5d6cf56d0d41678bbf620c27416 (diff)
downloadpython-coveragepy-831f7010f0cd1b20f054d3b90dae24445e36cb20.tar.gz
Last bit of testing the setup.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index c1a90cf..0b48843 100644
--- a/setup.py
+++ b/setup.py
@@ -139,6 +139,8 @@ class ve_build_ext(build_ext):
def build_extension(self, ext):
"""Wrap `build_extension` with `BuildFailed`."""
try:
+ # Uncomment to test compile failures:
+ # raise errors.CCompilerError("OOPS")
build_ext.build_extension(self, ext)
except ext_errors:
raise BuildFailed()