summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNed Batchelder <ned@nedbatchelder.com>2012-12-20 07:15:47 -0500
committerNed Batchelder <ned@nedbatchelder.com>2012-12-20 07:15:47 -0500
commited0729c8469cc333ef8a6c5b8f3c6738b6a01da6 (patch)
tree3182084543223cb705709ffd4c8b7449fc0ffddb /setup.py
parentee2a4a2e5f617ddf6bed4c1bade8deb86df6847d (diff)
downloadpython-coveragepy-ed0729c8469cc333ef8a6c5b8f3c6738b6a01da6.tar.gz
Properly create an Exception.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 53f08f9..62db5e7 100644
--- a/setup.py
+++ b/setup.py
@@ -121,7 +121,7 @@ if sys.platform == 'win32' and sys.version_info > (2, 6):
class BuildFailed(Exception):
"""Raise this to indicate the C extension wouldn't build."""
def __init__(self):
- Exception.__init__()
+ Exception.__init__(self)
self.cause = sys.exc_info()[1] # work around py 2/3 different syntax
class ve_build_ext(build_ext.build_ext):