summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNed Batchelder <ned@nedbatchelder.com>2016-12-17 14:08:19 -0500
committerNed Batchelder <ned@nedbatchelder.com>2016-12-17 14:08:19 -0500
commitf92548b8a3e0d3565fb12b7ee046c84c29a0a39d (patch)
tree95005eaa8ebb1a1d47062449b1e82c5b582c4397 /setup.py
parent2e842bb15920616aca9261c93ad834d0a843e5bc (diff)
downloadpython-coveragepy-f92548b8a3e0d3565fb12b7ee046c84c29a0a39d.tar.gz
Put a count of contributors into the authors string
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 6 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index b304864..0e89306 100644
--- a/setup.py
+++ b/setup.py
@@ -46,6 +46,11 @@ with open(cov_ver_py) as version_file:
with open("README.rst") as readme:
long_description = readme.read().replace("http://coverage.readthedocs.io", __url__)
+with open("CONTRIBUTORS.txt") as contributors:
+ paras = contributors.read().split("\n\n")
+ num_others = len(paras[-1].splitlines())
+ num_others += 1 # Count Gareth Rees, who is mentioned in the top paragraph.
+
classifier_list = classifiers.splitlines()
if version_info[3] == 'alpha':
@@ -86,7 +91,7 @@ setup_args = dict(
# We need to get HTML assets from our htmlfiles directory.
zip_safe=False,
- author='Ned Batchelder and others',
+ author='Ned Batchelder and {0} others'.format(num_others),
author_email='ned@nedbatchelder.com',
description=doc,
long_description=long_description,