summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py21
1 files changed, 1 insertions, 20 deletions
diff --git a/setup.py b/setup.py
index c67cb1a..afe3cde 100755
--- a/setup.py
+++ b/setup.py
@@ -3,30 +3,11 @@ from distutils.core import setup
version = "0.9.8"
-setup(name="fastimport",
- description="VCS fastimport/fastexport parser",
- version=version,
- author="Canonical Ltd",
- author_email="bazaar@lists.canonical.com",
- maintainer="Jelmer Vernooij",
- maintainer_email="jelmer@jelmer.uk",
- license="GNU GPL v2 or later",
- url="https://github.com/jelmer/python-fastimport",
+setup(version=version,
packages=['fastimport', 'fastimport.tests', 'fastimport.processors'],
scripts=[
'bin/fast-import-query',
'bin/fast-import-filter',
'bin/fast-import-info',
],
- classifiers=[
- 'Development Status :: 4 - Beta',
- 'License :: OSI Approved :: GNU General Public License v2 or later (GPLv2+)',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3.4',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: Implementation :: CPython',
- 'Programming Language :: Python :: Implementation :: PyPy',
- 'Operating System :: POSIX',
- 'Topic :: Software Development :: Version Control',
- ],
)