summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2013-05-18 09:02:07 -0700
committerMonty Taylor <mordred@inaugust.com>2013-05-18 09:02:07 -0700
commit4f9d4d051ac4bed9f4bd4f431491af4a75dd308b (patch)
treed63cde575125344965ca714908dae97f21406f99 /setup.py
parentca17541f33b4c65af7fe43e4de856334a8a866cd (diff)
downloadpython-glanceclient-4f9d4d051ac4bed9f4bd4f431491af4a75dd308b.tar.gz
Migrate to pbr.
Fixes bug 1179007. Change-Id: I99d571bbf37ef53366a96de088c249cb6fd23b0e
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py61
1 files changed, 17 insertions, 44 deletions
diff --git a/setup.py b/setup.py
index 543dd43..1e9882d 100644
--- a/setup.py
+++ b/setup.py
@@ -1,48 +1,21 @@
-import os
-import sys
+#!/usr/bin/env python
+# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
import setuptools
-from glanceclient.openstack.common import setup
-
-
-requires = setup.parse_requirements()
-dependency_links = setup.parse_dependency_links()
-tests_require = setup.parse_requirements(['tools/test-requires'])
-project = 'python-glanceclient'
-
-if sys.version_info < (2, 6):
- requires.append('simplejson')
-
-
-def read(fname):
- return open(os.path.join(os.path.dirname(__file__), fname)).read()
-
setuptools.setup(
- name=project,
- version=setup.get_version(project),
- description="Client library for OpenStack Image API",
- long_description=read('README.rst'),
- url='https://github.com/openstack/python-glanceclient',
- license='Apache',
- author='OpenStack Glance Contributors',
- author_email='glance@example.com',
- packages=setuptools.find_packages(exclude=['tests', 'tests.*']),
- include_package_data=True,
- classifiers=[
- 'Development Status :: 4 - Beta',
- 'Environment :: Console',
- 'Environment :: OpenStack',
- 'Intended Audience :: Developers',
- 'Intended Audience :: Information Technology',
- 'License :: OSI Approved :: Apache Software License',
- 'Operating System :: OS Independent',
- 'Programming Language :: Python',
- ],
- cmdclass=setup.get_cmdclass(),
- install_requires=requires,
- dependency_links=dependency_links,
- tests_require=tests_require,
- setup_requires=['setuptools-git>=0.4'],
- entry_points={'console_scripts': ['glance = glanceclient.shell:main']},
-)
+ setup_requires=['d2to1>=0.2.10,<0.3', 'pbr>=0.5,<0.6'],
+ d2to1=True)