summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJay Pipes <jaypipes@gmail.com>2012-02-29 16:42:26 -0500
committerJay Pipes <jaypipes@gmail.com>2012-02-29 16:42:26 -0500
commit972677fc3dc24a5084657fc337fb2b2981a30e0c (patch)
treefa5039f09ea51c021a924bfac1579eabb9e96de8 /setup.py
downloadpython-glanceclient-972677fc3dc24a5084657fc337fb2b2981a30e0c.tar.gz
Initial checkin for new CLI and client package
Copied mostly from python-keystoneclient with some Glance-specific stuff. README.rst shows what WILL be the way to do things, not what is currently coded :)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py42
1 files changed, 42 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..098d2d9
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,42 @@
+import os
+import sys
+from setuptools import setup, find_packages
+
+
+def read(fname):
+ return open(os.path.join(os.path.dirname(__file__), fname)).read()
+
+requirements = ['httplib2', 'prettytable']
+if sys.version_info < (2, 6):
+ requirements.append('simplejson')
+if sys.version_info < (2, 7):
+ requirements.append('argparse')
+
+setup(
+ name = "python-glanceclient",
+ version = "2012.1",
+ description = "Client library for OpenStack Glance API",
+ long_description = read('README.rst'),
+ url = 'https://github.com/openstack/python-glanceclient',
+ license = 'Apache',
+ author = 'Jay Pipes, based on work by Rackspace and Jacob Kaplan-Moss',
+ author_email = 'jay.pipes@gmail.com',
+ packages = find_packages(exclude=['tests', 'tests.*']),
+ classifiers = [
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: Information Technology',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ ],
+ install_requires = requirements,
+
+ tests_require = ["nose", "mock", "mox"],
+ test_suite = "nose.collector",
+
+ entry_points = {
+ 'console_scripts': ['glance = glanceclient.shell:main']
+ }
+)