summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBhuvan Arumugam <bhuvan@apache.org>2012-06-01 23:38:12 -0700
committerBhuvan Arumugam <bhuvan@apache.org>2012-06-02 00:04:12 -0700
commita1f8ea1c7f9849e0fb64c547d6456d2c3c38c5e8 (patch)
tree279b1b71294a1a42d52509953e94f002ad404b0d /setup.py
parentb9b897252868732763de60d829b5c8de188adf38 (diff)
downloadpython-glanceclient-a1f8ea1c7f9849e0fb64c547d6456d2c3c38c5e8.tar.gz
Auto generate AUTHORS file for glanceclient component.
Bug: 976267 Now that git commits are gated by CLA, we shouldn't enforce committers to add an entry in AUTHORS file. The AUTHORS file should be generated automatically, based on git commits. This commit fixes the problem. * AUTHORS Remove this file. * .gitignore Add AUTHORS file. * glanceclient/openstack/common/setup.py Sync changes from openstack-common. * setup.py Generate AUTHORS file before creating the package. * glanceclient/shell.py Pep8 fix. * tests/test_authors.py Remove this test case. Change-Id: I9e9d4da5ca3b147b483250dcf25a3b2a840123c2
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 4634ccd..750f9ac 100644
--- a/setup.py
+++ b/setup.py
@@ -3,6 +3,7 @@ import sys
import setuptools
+from glanceclient.openstack.common.setup import generate_authors
from glanceclient.openstack.common.setup import parse_requirements
from glanceclient.openstack.common.setup import parse_dependency_links
from glanceclient.openstack.common.setup import write_git_changelog
@@ -12,6 +13,7 @@ requires = parse_requirements()
dependency_links = parse_dependency_links()
tests_require = parse_requirements(['tools/test-requires'])
write_git_changelog()
+generate_authors()
if sys.version_info < (2, 6):
requires.append('simplejson')