summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-04-30 02:46:18 +0000
committerOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2014-04-30 02:46:18 +0000
commitb68d13bf8329bf5dbcc13ad82480a055b5ea4cc0 (patch)
tree9097034c14f50069bceca230413f9574fa48ea76 /setup.py
parentf2e0610628bf646003c40668adfa5a6c4318cbc3 (diff)
downloadpython-glanceclient-b68d13bf8329bf5dbcc13ad82480a055b5ea4cc0.tar.gz
Updated from global requirements
Change-Id: Ied7b0c3e2b0fc13abb04c859ec6887d7a8533c15
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 70c2b3f..7363757 100644
--- a/setup.py
+++ b/setup.py
@@ -17,6 +17,14 @@
# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
+# In python < 2.7.4, a lazy loading of package `pbr` will break
+# setuptools if some other modules registered functions in `atexit`.
+# solution from: http://bugs.python.org/issue15881#msg170215
+try:
+ import multiprocessing # noqa
+except ImportError:
+ pass
+
setuptools.setup(
setup_requires=['pbr'],
pbr=True)