summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAndreas Jaeger <aj@suse.com>2020-04-04 16:46:25 +0200
committerAndreas Jaeger <aj@suse.com>2020-04-04 16:47:34 +0200
commitbaa89534a3568363fdc518a587a7679657a048c7 (patch)
tree7059316f46a7a9e18eb81623027cdbb7456e21ac /setup.py
parent82da2378eaf1e2283ed623760d065cc972dd0871 (diff)
downloadpython-glanceclient-baa89534a3568363fdc518a587a7679657a048c7.tar.gz
Cleanup py27 support
Make a few cleanups: - Remove python 2.7 stanza from setup.py - Update classifiers - Update requirements, no need for python_version anymore Change-Id: I6b6dfb0959973abf0c2e8325006025db2a5d85d0
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 0 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 566d844..cd35c3c 100644
--- a/setup.py
+++ b/setup.py
@@ -13,17 +13,8 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
import setuptools
-# In python < 2.7.4, a lazy loading of package `pbr` will break
-# setuptools if some other modules registered functions in `atexit`.
-# solution from: http://bugs.python.org/issue15881#msg170215
-try:
- import multiprocessing # noqa
-except ImportError:
- pass
-
setuptools.setup(
setup_requires=['pbr>=2.0.0'],
pbr=True)