summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristian Clauss <cclauss@me.com>2019-11-09 08:48:19 +0100
committerGitHub <noreply@github.com>2019-11-09 08:48:19 +0100
commit9ca2e2139e35b717f970a9679105cbdaed54636f (patch)
tree14e9a9abab702fbd72862d29a432ade25f72a6b9 /setup.py
parent2f2790bdbcaa285a46166e48b743ebd6c7c82828 (diff)
downloadpython-json-patch-9ca2e2139e35b717f970a9679105cbdaed54636f.tar.gz
fixup! setup.py: Add Python 3.8 and remove 3.4
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 66f3319..b01af80 100644
--- a/setup.py
+++ b/setup.py
@@ -56,10 +56,10 @@ CLASSIFIERS = [
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: Implementation :: CPython',
'Programming Language :: Python :: Implementation :: PyPy',
'Topic :: Software Development :: Libraries',
@@ -79,7 +79,7 @@ setup(name=PACKAGE,
package_data={'': ['requirements.txt']},
scripts=['bin/jsondiff', 'bin/jsonpatch'],
classifiers=CLASSIFIERS,
- python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*',
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*',
project_urls={
'Website': 'https://github.com/stefankoegl/python-json-patch',
'Repository': 'https://github.com/stefankoegl/python-json-patch.git',