diff options
author | Daniel Hahler <github@thequod.de> | 2018-11-16 01:52:40 +0100 |
---|---|---|
committer | Waylan Limberg <waylan.limberg@icloud.com> | 2018-11-15 19:52:40 -0500 |
commit | d41adf5e37b7c04cddc524045b02eb47f4a1dbdd (patch) | |
tree | 057a9b66fc6bfed45307592b1389cd1d082dcd9f /setup.py | |
parent | 0c7924e38e96278b25eacbecc30c2ab3a2478138 (diff) | |
download | python-markdown-d41adf5e37b7c04cddc524045b02eb47f4a1dbdd.tar.gz |
Improve CI / testing (#754)
* Use "testing" extras_require
This centralized testing requirements and allows for
`pip install -e .[testing]` etc.
pytidylib is kept separate according to
https://github.com/Python-Markdown/markdown/pull/754/files#r233561159.
* Travis: simplify installation of deps
* Travis: use xenial by default, trusty for py34
* Travis: codecov: use flags
* Travis: only install aspell for checkspelling job
* Remove coverage version restriction
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 6 |
1 files changed, 6 insertions, 0 deletions
@@ -78,6 +78,12 @@ setup( packages=['markdown', 'markdown.extensions'], python_requires='>=2.7,!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*', install_requires=['setuptools >= 36'], + extras_require={ + 'testing': [ + 'coverage', + 'pyyaml', + ], + }, entry_points={ 'console_scripts': [ '%s = markdown.__main__:run' % SCRIPT_NAME, |