summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2014-11-21 04:47:18 +0100
committerVictor Stinner <victor.stinner@gmail.com>2014-11-21 04:47:18 +0100
commit6be69c3f9c7d809ee111054a5116567696480a32 (patch)
tree918a77d0a13f341ceb7c76a7645c648e75b55b50
parentec500753679a69831d22c538d6850a68eeedfbc5 (diff)
downloadaioeventlet-6be69c3f9c7d809ee111054a5116567696480a32.tar.gz
convert README to a sphinx documentation
-rw-r--r--README318
-rw-r--r--doc/Makefile177
-rw-r--r--doc/conf.py258
-rw-r--r--doc/index.rst313
-rw-r--r--doc/make.bat242
5 files changed, 1012 insertions, 296 deletions
diff --git a/README b/README
index 400d02c..19eda9b 100644
--- a/README
+++ b/README
@@ -1,296 +1,22 @@
-asyncio event loop implemented on top of eventlet.
-
-* Trollius project: http://trollius.readthedocs.org/
-* aiogreen at PyPI: https://pypi.python.org/pypi/aiogreen
-
-
-Usage
-=====
-
-Use aiogreen with asyncio
--------------------------
-
-aiogreen implements the asyncio API, see asyncio documentation:
-https://docs.python.org/dev/library/asyncio.html
-
-To use aiogreen with asyncio, set the event loop policy before using an event
-loop, example::
-
- import aiogreen
- import asyncio
-
- asyncio.set_event_loop_policy(aiogreen.EventLoopPolicy())
- # ....
-
-Adding this code should be enough to try examples of the asyncio documentation.
-
-Hello World::
-
- import aiogreen
- import asyncio
-
- def hello_world():
- print("Hello World")
- loop.stop()
-
- asyncio.set_event_loop_policy(aiogreen.EventLoopPolicy())
- loop = asyncio.get_event_loop()
- loop.call_soon(hello_world)
- loop.run_forever()
- loop.close()
-
-
-Use aiogreen with trollius
--------------------------
-
-To support Python 2, you can use Trollius which uses ``yield`` instead
-of ``yield from`` for coroutines:
-http://trollius.readthedocs.org/
-
-To use aiogreen with trollius, set the event loop policy before using an event
-loop, example::
-
- import aiogreen
- import trollius
-
- trollius.set_event_loop_policy(aiogreen.EventLoopPolicy())
- # ....
-
-Hello World::
-
- import aiogreen
- import trollius as asyncio
-
- def hello_world():
- print("Hello World")
- loop.stop()
-
- asyncio.set_event_loop_policy(aiogreen.EventLoopPolicy())
- loop = asyncio.get_event_loop()
- loop.call_soon(hello_world)
- loop.run_forever()
- loop.close()
-
-
-Use a greenthread in a coroutine
---------------------------------
-
-Use the ``wrap_greenthread(gt)`` function to wrap a greenthread into a Future
-object. The Future object waits for the completion of a greenthread.
-
-Example with asyncio::
-
- def slow_sum(x, y):
- eventlet.sleep(1.0)
- return x + y
-
- @asyncio.coroutine
- def coro_sum():
- gt = eventlet.spawn(slow_sum, 1, 2)
- fut = aiogreen.wrap_greenthread(gt, loop=loop)
- result = yield from fut
- return result
-
-Note: In debug mode, when a greenthread raises an exception, the exception is
-logged to sys.stderr by eventlet, even if it is correctly copied to the Future
-object.
-
-
-Use a coroutine in a greenthread
---------------------------------
-
-Use the ``link_future(future)`` function to wait for a future or a task from a
-greenthread. The function returns the result or raise the exception of the
-future.
-
-Example with asyncio::
-
- def coro_slow_sum(x, y):
- yield from asyncio.sleep(1.0)
- return x + y
-
- def green_sum():
- task = asyncio.async(coro_slow_sum(1, 2))
- value = aiogreen.link_future(task)
- return value
-
-
-API
-===
-
-Functions which are not in asyncio:
-
-* ``link_future(future)``: wait for a future (or a task) from a greenthread,
- return the result or raise the exception of the future
-* ``wrap_greenthread(gt)``: wrap a greenthread into a Future object
-
-
-Installation
-============
-
-Requirements:
-
-- eventlet 0.14 or newer
-- asyncio or trollius:
-
- * Python 3.4 and newer: asyncio is now part of the stdlib
- * Python 3.3: need Tulip 0.4.1 or newer (pip install asyncio),
- but Tulip 3.4.1 or newer is recommended
- * Python 2.6-3.2: need Trollius 0.3 or newer (pip install trollius),
- but Trollius 1.0 or newer is recommended
-
-Type::
-
- pip install aiogreen
-
-or::
-
- python setup.py install
-
-
-Run tests
-=========
-
-Run tests with tox
-------------------
-
-The `tox project <https://testrun.org/tox/latest/>`_ can be used to build a
-virtual environment with all runtime and test dependencies and run tests
-against different Python versions (2.6, 2.7, 3.2, 3.3).
-
-For example, to run tests with Python 2.7, just type::
-
- tox -e py27
-
-To run tests against other Python versions:
-
-* ``py26``: Python 2.6
-* ``py27``: Python 2.7
-* ``py27_patch``: Python 2.7 with eventlet monkey patching
-* ``py32``: Python 3.2
-* ``py33``: Python 3.3
-* ``py34``: Python 3.4
-
-Run tests manually
-------------------
-
-Run the following command from the directory of the aiogreen project:
-
- python runtests.py -r
-
-
-Changelog
-=========
-
-Version 0.2 (development version)
----------------------------------
-
-The core of the event loop was rewritten to fits better in asyncio and
-eventlet. aiogreen now reuses more code from asyncio/trollius. The code
-handling file descriptors was also fixed to respect asyncio contract:
-only call the callback once per loop iteration.
-
-Changes:
-
-* Add the ``link_future(future)`` function: wait for a future from a
- greenthread.
-* Add the ``wrap_greenthread(gt)`` function: wrap a greenthread into a Future
-* Support also eventlet 0.14, not only eventlet 0.15 or newer
-* Support eventlet with monkey-patching
-* Rewrite the code handling file descriptors to ensure that the listener is
- only called once per loop iteration, to respect asyncio specification.
-* Simplify the loop iteration: remove custom code to reuse instead the
- asyncio/trollius code (_run_once)
-* Reuse call_soon, call_soon_threadsafe, call_at, call_later from
- asyncio/trollius, remove custom code
-* sock_connect() is now asynchronous
-* Add a suite of automated unit tests
-* Fix EventLoop.stop(): don't stop immediatly, but schedule stopping the event
- loop with call_soon()
-* Add tox.ini to run tests with tox
-* Setting debug mode of the event loop doesn't enable "debug_blocking" of
- eventlet on Windows anymore, the feature is not implemented on Windows
- in eventlet.
-* add_reader() and add_writer() now cancels the previous handle and sets
- a new handle
-* In debug mode, detect calls to call_soon() from greenthreads which are not
- threadsafe (would not wake up the event loop).
-* Only set "debug_exceptions" of the eventlet hub when the debug mode of the
- event loop is enabled.
-
-2014-11-19: version 0.1
------------------------
-
-* First public release
-
-
-Implemented
-===========
-
-Methods:
-
-* call_at()
-* call_later()
-* call_soon()
-* run_forever()
-* run_in_executor()
-* run_until_complete()
-* create_connection(): TCP client
-* stop()
-* coroutines and tasks
-
-Tests of aiogreen 0.1:
-
-* Tested on Python 2.7, 3.3 and 3.5
-* Tested on Linux and Windows
-* Tested with Trollius 1.0, 1.0.1 and 1.0.2
-* Tested with asyncio 0.4.1 and 3.4.2
-
-
-To do (Not supported)
-=====================
-
-* add_reader() does only support one callback per file descriptor currently.
-* run an event loop in a thread different than the main thread
-* sockets: create_server, sock_recv
-* pipes: connect_read_pipe
-* subprocesses: need pipes
-* signal handlers: add_signal_handler (only for pyevent hub?)
-* tox.ini: add py33_patch. eventlet with Python 3 and monkey-patch causes
- an issue in importlib.
-
-
-eventlet issues
-===============
-
-* eventlet monkey patching on Python 3 is incomplete. The most blocking issue
- is in the importlib: the thread module is patched to use greenthreads, but
- importlib really need to work on real threads. Pull request:
- https://github.com/eventlet/eventlet/pull/168
-* eventlet.tpool.setup() seems to be broken on Windows in eventlet 0.15.
- Pull request:
- https://github.com/eventlet/eventlet/pull/167
-* hub.debug_blocking is implemented with signal.alarm() which is is not
- available on Windows.
-
-
-eventlet and Python 3
-=====================
-
-Issues:
-
-* https://github.com/eventlet/eventlet/issues/6 (root py3 issue)
-* https://github.com/eventlet/eventlet/issues/157 (py3 related?)
-* https://github.com/eventlet/eventlet/issues/153 (py3 related?)
-
-Pull requests:
-
-* https://github.com/eventlet/eventlet/pull/99 : complete monkey-patching
-* => commit: https://github.com/therve/eventlet/commit/9c3118162cf1ca1e50be330ba2a289f054c48d3c
-* https://github.com/eventlet/eventlet/pull/160 (py3 related?)
-
-OpenStack Kilo Summit:
-
-* https://etherpad.openstack.org/p/kilo-oslo-python-3
-* https://etherpad.openstack.org/p/kilo-oslo-oslo.messaging
-* https://etherpad.openstack.org/p/py34-transition (tangentially related)
+aiogreen implements the asyncio API on top of eventet. It makes possible to
+write asyncio code in a project currently written for eventlet.
+
+aiogreen allows to use greenthreads in asyncio coroutines, and to use asyncio
+coroutines, tasks and futures in greenthreads: see ``link_future()`` and
+``wrap_greenthread()`` functions.
+
+The main visible difference between trollius and aiogreen is that
+``run_forever()``: ``run_forever()`` blocks with trollius, whereas it runs in a
+greenthread with aiogreen. It means that it's possible to call
+``run_forever()`` in the main thread and execute other greenthreads in
+parallel.
+
+* `aiogreen documentation <http://aiogreen.readthedocs.org/>`_
+* `asyncio documentation <http://docs.python.org/dev/library/asyncio.html>`_
+* `trollus documentation <http://trollius.readthedocs.org/>`_
+* `aiogreen project in the Python Cheeseshop (PyPI)
+ <https://pypi.python.org/pypi/aiogreen>`_
+* `aiogreen project at Bitbucket <https://bitbucket.org/haypo/aiogreen>`_
+* Copyright/license: Open source, Apache 2.0. Enjoy!
+
+See also the `Tulip project <http://code.google.com/p/tulip/>`_.
diff --git a/doc/Makefile b/doc/Makefile
new file mode 100644
index 0000000..a3d64ee
--- /dev/null
+++ b/doc/Makefile
@@ -0,0 +1,177 @@
+# Makefile for Sphinx documentation
+#
+
+# You can set these variables from the command line.
+SPHINXOPTS =
+SPHINXBUILD = sphinx-build
+PAPER =
+BUILDDIR = build
+
+# User-friendly check for sphinx-build
+ifeq ($(shell which $(SPHINXBUILD) >/dev/null 2>&1; echo $$?), 1)
+$(error The '$(SPHINXBUILD)' command was not found. Make sure you have Sphinx installed, then set the SPHINXBUILD environment variable to point to the full path of the '$(SPHINXBUILD)' executable. Alternatively you can add the directory with the executable to your PATH. If you don't have Sphinx installed, grab it from http://sphinx-doc.org/)
+endif
+
+# Internal variables.
+PAPEROPT_a4 = -D latex_paper_size=a4
+PAPEROPT_letter = -D latex_paper_size=letter
+ALLSPHINXOPTS = -d $(BUILDDIR)/doctrees $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
+# the i18n builder cannot share the environment and doctrees with the others
+I18NSPHINXOPTS = $(PAPEROPT_$(PAPER)) $(SPHINXOPTS) .
+
+.PHONY: help clean html dirhtml singlehtml pickle json htmlhelp qthelp devhelp epub latex latexpdf text man changes linkcheck doctest gettext
+
+help:
+ @echo "Please use \`make <target>' where <target> is one of"
+ @echo " html to make standalone HTML files"
+ @echo " dirhtml to make HTML files named index.html in directories"
+ @echo " singlehtml to make a single large HTML file"
+ @echo " pickle to make pickle files"
+ @echo " json to make JSON files"
+ @echo " htmlhelp to make HTML files and a HTML help project"
+ @echo " qthelp to make HTML files and a qthelp project"
+ @echo " devhelp to make HTML files and a Devhelp project"
+ @echo " epub to make an epub"
+ @echo " latex to make LaTeX files, you can set PAPER=a4 or PAPER=letter"
+ @echo " latexpdf to make LaTeX files and run them through pdflatex"
+ @echo " latexpdfja to make LaTeX files and run them through platex/dvipdfmx"
+ @echo " text to make text files"
+ @echo " man to make manual pages"
+ @echo " texinfo to make Texinfo files"
+ @echo " info to make Texinfo files and run them through makeinfo"
+ @echo " gettext to make PO message catalogs"
+ @echo " changes to make an overview of all changed/added/deprecated items"
+ @echo " xml to make Docutils-native XML files"
+ @echo " pseudoxml to make pseudoxml-XML files for display purposes"
+ @echo " linkcheck to check all external links for integrity"
+ @echo " doctest to run all doctests embedded in the documentation (if enabled)"
+
+clean:
+ rm -rf $(BUILDDIR)/*
+
+html:
+ $(SPHINXBUILD) -b html $(ALLSPHINXOPTS) $(BUILDDIR)/html
+ @echo
+ @echo "Build finished. The HTML pages are in $(BUILDDIR)/html."
+
+dirhtml:
+ $(SPHINXBUILD) -b dirhtml $(ALLSPHINXOPTS) $(BUILDDIR)/dirhtml
+ @echo
+ @echo "Build finished. The HTML pages are in $(BUILDDIR)/dirhtml."
+
+singlehtml:
+ $(SPHINXBUILD) -b singlehtml $(ALLSPHINXOPTS) $(BUILDDIR)/singlehtml
+ @echo
+ @echo "Build finished. The HTML page is in $(BUILDDIR)/singlehtml."
+
+pickle:
+ $(SPHINXBUILD) -b pickle $(ALLSPHINXOPTS) $(BUILDDIR)/pickle
+ @echo
+ @echo "Build finished; now you can process the pickle files."
+
+json:
+ $(SPHINXBUILD) -b json $(ALLSPHINXOPTS) $(BUILDDIR)/json
+ @echo
+ @echo "Build finished; now you can process the JSON files."
+
+htmlhelp:
+ $(SPHINXBUILD) -b htmlhelp $(ALLSPHINXOPTS) $(BUILDDIR)/htmlhelp
+ @echo
+ @echo "Build finished; now you can run HTML Help Workshop with the" \
+ ".hhp project file in $(BUILDDIR)/htmlhelp."
+
+qthelp:
+ $(SPHINXBUILD) -b qthelp $(ALLSPHINXOPTS) $(BUILDDIR)/qthelp
+ @echo
+ @echo "Build finished; now you can run "qcollectiongenerator" with the" \
+ ".qhcp project file in $(BUILDDIR)/qthelp, like this:"
+ @echo "# qcollectiongenerator $(BUILDDIR)/qthelp/aiogreen.qhcp"
+ @echo "To view the help file:"
+ @echo "# assistant -collectionFile $(BUILDDIR)/qthelp/aiogreen.qhc"
+
+devhelp:
+ $(SPHINXBUILD) -b devhelp $(ALLSPHINXOPTS) $(BUILDDIR)/devhelp
+ @echo
+ @echo "Build finished."
+ @echo "To view the help file:"
+ @echo "# mkdir -p $$HOME/.local/share/devhelp/aiogreen"
+ @echo "# ln -s $(BUILDDIR)/devhelp $$HOME/.local/share/devhelp/aiogreen"
+ @echo "# devhelp"
+
+epub:
+ $(SPHINXBUILD) -b epub $(ALLSPHINXOPTS) $(BUILDDIR)/epub
+ @echo
+ @echo "Build finished. The epub file is in $(BUILDDIR)/epub."
+
+latex:
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ @echo
+ @echo "Build finished; the LaTeX files are in $(BUILDDIR)/latex."
+ @echo "Run \`make' in that directory to run these through (pdf)latex" \
+ "(use \`make latexpdf' here to do that automatically)."
+
+latexpdf:
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ @echo "Running LaTeX files through pdflatex..."
+ $(MAKE) -C $(BUILDDIR)/latex all-pdf
+ @echo "pdflatex finished; the PDF files are in $(BUILDDIR)/latex."
+
+latexpdfja:
+ $(SPHINXBUILD) -b latex $(ALLSPHINXOPTS) $(BUILDDIR)/latex
+ @echo "Running LaTeX files through platex and dvipdfmx..."
+ $(MAKE) -C $(BUILDDIR)/latex all-pdf-ja
+ @echo "pdflatex finished; the PDF files are in $(BUILDDIR)/latex."
+
+text:
+ $(SPHINXBUILD) -b text $(ALLSPHINXOPTS) $(BUILDDIR)/text
+ @echo
+ @echo "Build finished. The text files are in $(BUILDDIR)/text."
+
+man:
+ $(SPHINXBUILD) -b man $(ALLSPHINXOPTS) $(BUILDDIR)/man
+ @echo
+ @echo "Build finished. The manual pages are in $(BUILDDIR)/man."
+
+texinfo:
+ $(SPHINXBUILD) -b texinfo $(ALLSPHINXOPTS) $(BUILDDIR)/texinfo
+ @echo
+ @echo "Build finished. The Texinfo files are in $(BUILDDIR)/texinfo."
+ @echo "Run \`make' in that directory to run these through makeinfo" \
+ "(use \`make info' here to do that automatically)."
+
+info:
+ $(SPHINXBUILD) -b texinfo $(ALLSPHINXOPTS) $(BUILDDIR)/texinfo
+ @echo "Running Texinfo files through makeinfo..."
+ make -C $(BUILDDIR)/texinfo info
+ @echo "makeinfo finished; the Info files are in $(BUILDDIR)/texinfo."
+
+gettext:
+ $(SPHINXBUILD) -b gettext $(I18NSPHINXOPTS) $(BUILDDIR)/locale
+ @echo
+ @echo "Build finished. The message catalogs are in $(BUILDDIR)/locale."
+
+changes:
+ $(SPHINXBUILD) -b changes $(ALLSPHINXOPTS) $(BUILDDIR)/changes
+ @echo
+ @echo "The overview file is in $(BUILDDIR)/changes."
+
+linkcheck:
+ $(SPHINXBUILD) -b linkcheck $(ALLSPHINXOPTS) $(BUILDDIR)/linkcheck
+ @echo
+ @echo "Link check complete; look for any errors in the above output " \
+ "or in $(BUILDDIR)/linkcheck/output.txt."
+
+doctest:
+ $(SPHINXBUILD) -b doctest $(ALLSPHINXOPTS) $(BUILDDIR)/doctest
+ @echo "Testing of doctests in the sources finished, look at the " \
+ "results in $(BUILDDIR)/doctest/output.txt."
+
+xml:
+ $(SPHINXBUILD) -b xml $(ALLSPHINXOPTS) $(BUILDDIR)/xml
+ @echo
+ @echo "Build finished. The XML files are in $(BUILDDIR)/xml."
+
+pseudoxml:
+ $(SPHINXBUILD) -b pseudoxml $(ALLSPHINXOPTS) $(BUILDDIR)/pseudoxml
+ @echo
+ @echo "Build finished. The pseudo-XML files are in $(BUILDDIR)/pseudoxml."
diff --git a/doc/conf.py b/doc/conf.py
new file mode 100644
index 0000000..d1d7d97
--- /dev/null
+++ b/doc/conf.py
@@ -0,0 +1,258 @@
+# -*- coding: utf-8 -*-
+#
+# aiogreen documentation build configuration file, created by
+# sphinx-quickstart on Fri Nov 21 04:29:49 2014.
+#
+# This file is execfile()d with the current directory set to its
+# containing dir.
+#
+# Note that not all possible configuration values are present in this
+# autogenerated file.
+#
+# All configuration values have a default; values that are commented out
+# serve to show the default.
+
+import sys
+import os
+
+# If extensions (or modules to document with autodoc) are in another directory,
+# add these directories to sys.path here. If the directory is relative to the
+# documentation root, use os.path.abspath to make it absolute, like shown here.
+#sys.path.insert(0, os.path.abspath('.'))
+
+# -- General configuration ------------------------------------------------
+
+# If your documentation needs a minimal Sphinx version, state it here.
+#needs_sphinx = '1.0'
+
+# Add any Sphinx extension module names here, as strings. They can be
+# extensions coming with Sphinx (named 'sphinx.ext.*') or your custom
+# ones.
+extensions = []
+
+# Add any paths that contain templates here, relative to this directory.
+templates_path = ['templates']
+
+# The suffix of source filenames.
+source_suffix = '.rst'
+
+# The encoding of source files.
+#source_encoding = 'utf-8-sig'
+
+# The master toctree document.
+master_doc = 'index'
+
+# General information about the project.
+project = u'aiogreen'
+copyright = u'2014, Victor Stinner'
+
+# The version info for the project you're documenting, acts as replacement for
+# |version| and |release|, also used in various other places throughout the
+# built documents.
+#
+# The short X.Y version.
+version = '0.2'
+# The full version, including alpha/beta/rc tags.
+release = '0.2'
+
+# The language for content autogenerated by Sphinx. Refer to documentation
+# for a list of supported languages.
+#language = None
+
+# There are two options for replacing |today|: either, you set today to some
+# non-false value, then it is used:
+#today = ''
+# Else, today_fmt is used as the format for a strftime call.
+#today_fmt = '%B %d, %Y'
+
+# List of patterns, relative to source directory, that match files and
+# directories to ignore when looking for source files.
+exclude_patterns = ['build']
+
+# The reST default role (used for this markup: `text`) to use for all
+# documents.
+#default_role = None
+
+# If true, '()' will be appended to :func: etc. cross-reference text.
+#add_function_parentheses = True
+
+# If true, the current module name will be prepended to all description
+# unit titles (such as .. function::).
+#add_module_names = True
+
+# If true, sectionauthor and moduleauthor directives will be shown in the
+# output. They are ignored by default.
+#show_authors = False
+
+# The name of the Pygments (syntax highlighting) style to use.
+pygments_style = 'sphinx'
+
+# A list of ignored prefixes for module index sorting.
+#modindex_common_prefix = []
+
+# If true, keep warnings as "system message" paragraphs in the built documents.
+#keep_warnings = False
+
+
+# -- Options for HTML output ----------------------------------------------
+
+# The theme to use for HTML and HTML Help pages. See the documentation for
+# a list of builtin themes.
+html_theme = 'default'
+
+# Theme options are theme-specific and customize the look and feel of a theme
+# further. For a list of options available for each theme, see the
+# documentation.
+#html_theme_options = {}
+
+# Add any paths that contain custom themes here, relative to this directory.
+#html_theme_path = []
+
+# The name for this set of Sphinx documents. If None, it defaults to
+# "<project> v<release> documentation".
+#html_title = None
+
+# A shorter title for the navigation bar. Default is the same as html_title.
+#html_short_title = None
+
+# The name of an image file (relative to this directory) to place at the top
+# of the sidebar.
+#html_logo = None
+
+# The name of an image file (within the static path) to use as favicon of the
+# docs. This file should be a Windows icon file (.ico) being 16x16 or 32x32
+# pixels large.
+#html_favicon = None
+
+# Add any paths that contain custom static files (such as style sheets) here,
+# relative to this directory. They are copied after the builtin static files,
+# so a file named "default.css" will overwrite the builtin "default.css".
+html_static_path = ['_static']
+
+# Add any extra paths that contain custom files (such as robots.txt or
+# .htaccess) here, relative to this directory. These files are copied
+# directly to the root of the documentation.
+#html_extra_path = []
+
+# If not '', a 'Last updated on:' timestamp is inserted at every page bottom,
+# using the given strftime format.
+#html_last_updated_fmt = '%b %d, %Y'
+
+# If true, SmartyPants will be used to convert quotes and dashes to
+# typographically correct entities.
+#html_use_smartypants = True
+
+# Custom sidebar templates, maps document names to template names.
+#html_sidebars = {}
+
+# Additional templates that should be rendered to pages, maps page names to
+# template names.
+#html_additional_pages = {}
+
+# If false, no module index is generated.
+#html_domain_indices = True
+
+# If false, no index is generated.
+#html_use_index = True
+
+# If true, the index is split into individual pages for each letter.
+#html_split_index = False
+
+# If true, links to the reST sources are added to the pages.
+#html_show_sourcelink = True
+
+# If true, "Created using Sphinx" is shown in the HTML footer. Default is True.
+#html_show_sphinx = True
+
+# If true, "(C) Copyright ..." is shown in the HTML footer. Default is True.
+#html_show_copyright = True
+
+# If true, an OpenSearch description file will be output, and all pages will
+# contain a <link> tag referring to it. The value of this option must be the
+# base URL from which the finished HTML is served.
+#html_use_opensearch = ''
+
+# This is the file name suffix for HTML files (e.g. ".xhtml").
+#html_file_suffix = None
+
+# Output file base name for HTML help builder.
+htmlhelp_basename = 'aiogreendoc'
+
+
+# -- Options for LaTeX output ---------------------------------------------
+
+latex_elements = {
+# The paper size ('letterpaper' or 'a4paper').
+#'papersize': 'letterpaper',
+
+# The font size ('10pt', '11pt' or '12pt').
+#'pointsize': '10pt',
+
+# Additional stuff for the LaTeX preamble.
+#'preamble': '',
+}
+
+# Grouping the document tree into LaTeX files. List of tuples
+# (source start file, target name, title,
+# author, documentclass [howto, manual, or own class]).
+latex_documents = [
+ ('index', 'aiogreen.tex', u'aiogreen Documentation',
+ u'Victor Stinner', 'manual'),
+]
+
+# The name of an image file (relative to this directory) to place at the top of
+# the title page.
+#latex_logo = None
+
+# For "manual" documents, if this is true, then toplevel headings are parts,
+# not chapters.
+#latex_use_parts = False
+
+# If true, show page references after internal links.
+#latex_show_pagerefs = False
+
+# If true, show URL addresses after external links.
+#latex_show_urls = False
+
+# Documents to append as an appendix to all manuals.
+#latex_appendices = []
+
+# If false, no module index is generated.
+#latex_domain_indices = True
+
+
+# -- Options for manual page output ---------------------------------------
+
+# One entry per manual page. List of tuples
+# (source start file, name, description, authors, manual section).
+man_pages = [
+ ('index', 'aiogreen', u'aiogreen Documentation',
+ [u'Victor Stinner'], 1)
+]
+
+# If true, show URL addresses after external links.
+#man_show_urls = False
+
+
+# -- Options for Texinfo output -------------------------------------------
+
+# Grouping the document tree into Texinfo files. List of tuples
+# (source start file, target name, title, author,
+# dir menu entry, description, category)
+texinfo_documents = [
+ ('index', 'aiogreen', u'aiogreen Documentation',
+ u'Victor Stinner', 'aiogreen', 'One line description of project.',
+ 'Miscellaneous'),
+]
+
+# Documents to append as an appendix to all manuals.
+#texinfo_appendices = []
+
+# If false, no module index is generated.
+#texinfo_domain_indices = True
+
+# How to display URL addresses: 'footnote', 'no', or 'inline'.
+#texinfo_show_urls = 'footnote'
+
+# If true, do not generate a @detailmenu in the "Top" node's menu.
+#texinfo_no_detailmenu = False
diff --git a/doc/index.rst b/doc/index.rst
new file mode 100644
index 0000000..66ac0b5
--- /dev/null
+++ b/doc/index.rst
@@ -0,0 +1,313 @@
+aiogreen
+========
+
+aiogreen implements the asyncio API on top of eventet. It makes possible to
+write asyncio code in a project currently written for eventlet.
+
+aiogreen allows to use greenthreads in asyncio coroutines, and to use asyncio
+coroutines, tasks and futures in greenthreads: see :func:`link_future` and
+:func:`wrap_greenthread` functions.
+
+The main visible difference between trollius and aiogreen is that
+``run_forever()``: ``run_forever()`` blocks with trollius, whereas it runs in a
+greenthread with aiogreen. It means that it's possible to call
+``run_forever()`` in the main thread and execute other greenthreads in
+parallel.
+
+* `aiogreen documentation <http://aiogreen.readthedocs.org/>`_
+* `asyncio documentation <http://docs.python.org/dev/library/asyncio.html>`_
+* `trollus documentation <http://trollius.readthedocs.org/>`_
+* `aiogreen project in the Python Cheeseshop (PyPI)
+ <https://pypi.python.org/pypi/aiogreen>`_
+* `aiogreen project at Bitbucket <https://bitbucket.org/haypo/aiogreen>`_
+* Copyright/license: Open source, Apache 2.0. Enjoy!
+
+See also the `Tulip project <http://code.google.com/p/tulip/>`_.
+
+
+Usage
+=====
+
+Use aiogreen with trollius
+-------------------------
+
+To support Python 2, you can use Trollius which uses ``yield`` instead
+of ``yield from`` for coroutines:
+http://trollius.readthedocs.org/
+
+To use aiogreen with trollius, set the event loop policy before using an event
+loop, example::
+
+ import aiogreen
+ import trollius
+
+ trollius.set_event_loop_policy(aiogreen.EventLoopPolicy())
+ # ....
+
+Hello World::
+
+ import aiogreen
+ import trollius as asyncio
+
+ def hello_world():
+ print("Hello World")
+ loop.stop()
+
+ asyncio.set_event_loop_policy(aiogreen.EventLoopPolicy())
+ loop = asyncio.get_event_loop()
+ loop.call_soon(hello_world)
+ loop.run_forever()
+ loop.close()
+
+
+Use aiogreen with asyncio
+-------------------------
+
+aiogreen implements the asyncio API, see asyncio documentation:
+https://docs.python.org/dev/library/asyncio.html
+
+eventlet 0.15 supports Python 3 if monkey-patching is not used.
+
+To use aiogreen with asyncio, set the event loop policy before using an event
+loop, example::
+
+ import aiogreen
+ import asyncio
+
+ asyncio.set_event_loop_policy(aiogreen.EventLoopPolicy())
+ # ....
+
+Adding this code should be enough to try examples of the asyncio documentation.
+
+Hello World::
+
+ import aiogreen
+ import asyncio
+
+ def hello_world():
+ print("Hello World")
+ loop.stop()
+
+ asyncio.set_event_loop_policy(aiogreen.EventLoopPolicy())
+ loop = asyncio.get_event_loop()
+ loop.call_soon(hello_world)
+ loop.run_forever()
+ loop.close()
+
+
+API
+===
+
+aiogreen specific functions:
+
+.. function:: link_future(future)
+
+ Wait for a future (or a task) from a greenthread.
+ Return the result or raise the exception of the future.
+
+ Example with asyncio::
+
+ def coro_slow_sum(x, y):
+ yield from asyncio.sleep(1.0)
+ return x + y
+
+ def green_sum():
+ task = asyncio.async(coro_slow_sum(1, 2))
+ value = aiogreen.link_future(task)
+ return value
+
+.. function:: wrap_greenthread(gt)
+
+ Wrap a greenthread into a Future object.
+
+ The Future object waits for the completion of a greenthread.
+
+ Example with asyncio::
+
+ def slow_sum(x, y):
+ eventlet.sleep(1.0)
+ return x + y
+
+ @asyncio.coroutine
+ def coro_sum():
+ gt = eventlet.spawn(slow_sum, 1, 2)
+ fut = aiogreen.wrap_greenthread(gt, loop=loop)
+ result = yield from fut
+ return result
+
+ .. note::
+ If the debug mode of event loop is set, when a greenthread raises an
+ exception, the exception is logged to ``sys.stderr`` by eventlet, even if
+ the exception is copied to the Future object as expected.
+
+
+Installation
+============
+
+Requirements:
+
+- eventlet 0.14 or newer
+- asyncio or trollius:
+
+ * Python 3.4 and newer: asyncio is now part of the stdlib
+ * Python 3.3: need Tulip 0.4.1 or newer (pip install asyncio),
+ but Tulip 3.4.1 or newer is recommended
+ * Python 2.6-3.2: need Trollius 0.3 or newer (pip install trollius),
+ but Trollius 1.0 or newer is recommended
+
+Type::
+
+ pip install aiogreen
+
+or::
+
+ python setup.py install
+
+
+Run tests
+=========
+
+Run tests with tox
+------------------
+
+The `tox project <https://testrun.org/tox/latest/>`_ can be used to build a
+virtual environment with all runtime and test dependencies and run tests
+against different Python versions (2.6, 2.7, 3.2, 3.3).
+
+For example, to run tests with Python 2.7, just type::
+
+ tox -e py27
+
+To run tests against other Python versions:
+
+* ``py26``: Python 2.6
+* ``py27``: Python 2.7
+* ``py27_patch``: Python 2.7 with eventlet monkey patching
+* ``py32``: Python 3.2
+* ``py33``: Python 3.3
+* ``py34``: Python 3.4
+
+Run tests manually
+------------------
+
+Run the following command from the directory of the aiogreen project:
+
+ python runtests.py -r
+
+
+Changelog
+=========
+
+Version 0.2 (development version)
+---------------------------------
+
+The core of the event loop was rewritten to fits better in asyncio and
+eventlet. aiogreen now reuses more code from asyncio/trollius. The code
+handling file descriptors was also fixed to respect asyncio contract:
+only call the callback once per loop iteration.
+
+Changes:
+
+* Add a Sphinx documentation published at http://aiogreen.readthedocs.org/
+* Add the :func:`link_future` function: wait for a future from a
+ greenthread.
+* Add the :func:`wrap_greenthread` function: wrap a greenthread into a Future
+* Support also eventlet 0.14, not only eventlet 0.15 or newer
+* Support eventlet with monkey-patching
+* Rewrite the code handling file descriptors to ensure that the listener is
+ only called once per loop iteration, to respect asyncio specification.
+* Simplify the loop iteration: remove custom code to reuse instead the
+ asyncio/trollius code (_run_once)
+* Reuse call_soon, call_soon_threadsafe, call_at, call_later from
+ asyncio/trollius, remove custom code
+* sock_connect() is now asynchronous
+* Add a suite of automated unit tests
+* Fix EventLoop.stop(): don't stop immediatly, but schedule stopping the event
+ loop with call_soon()
+* Add tox.ini to run tests with tox
+* Setting debug mode of the event loop doesn't enable "debug_blocking" of
+ eventlet on Windows anymore, the feature is not implemented on Windows
+ in eventlet.
+* add_reader() and add_writer() now cancels the previous handle and sets
+ a new handle
+* In debug mode, detect calls to call_soon() from greenthreads which are not
+ threadsafe (would not wake up the event loop).
+* Only set "debug_exceptions" of the eventlet hub when the debug mode of the
+ event loop is enabled.
+
+2014-11-19: version 0.1
+-----------------------
+
+* First public release
+
+
+Implemented
+===========
+
+Methods:
+
+* call_at()
+* call_later()
+* call_soon()
+* run_forever()
+* run_in_executor()
+* run_until_complete()
+* create_connection(): TCP client
+* stop()
+* coroutines and tasks
+
+Tests of aiogreen 0.1:
+
+* Tested on Python 2.7, 3.3 and 3.5
+* Tested on Linux and Windows
+* Tested with Trollius 1.0, 1.0.1 and 1.0.2
+* Tested with asyncio 0.4.1 and 3.4.2
+
+
+To do (Not supported)
+=====================
+
+* add_reader() does only support one callback per file descriptor currently.
+* run an event loop in a thread different than the main thread
+* sockets: create_server, sock_recv
+* pipes: connect_read_pipe
+* subprocesses: need pipes
+* signal handlers: add_signal_handler (only for pyevent hub?)
+* tox.ini: add py33_patch. eventlet with Python 3 and monkey-patch causes
+ an issue in importlib.
+
+
+eventlet issues
+===============
+
+* eventlet monkey patching on Python 3 is incomplete. The most blocking issue
+ is in the importlib: the thread module is patched to use greenthreads, but
+ importlib really need to work on real threads. Pull request:
+ https://github.com/eventlet/eventlet/pull/168
+* eventlet.tpool.setup() seems to be broken on Windows in eventlet 0.15.
+ Pull request:
+ https://github.com/eventlet/eventlet/pull/167
+* hub.debug_blocking is implemented with signal.alarm() which is is not
+ available on Windows.
+
+
+eventlet and Python 3
+=====================
+
+Issues:
+
+* https://github.com/eventlet/eventlet/issues/6 (root py3 issue)
+* https://github.com/eventlet/eventlet/issues/157 (py3 related?)
+* https://github.com/eventlet/eventlet/issues/153 (py3 related?)
+
+Pull requests:
+
+* https://github.com/eventlet/eventlet/pull/99 : complete monkey-patching
+* => commit: https://github.com/therve/eventlet/commit/9c3118162cf1ca1e50be330ba2a289f054c48d3c
+* https://github.com/eventlet/eventlet/pull/160 (py3 related?)
+
+OpenStack Kilo Summit:
+
+* https://etherpad.openstack.org/p/kilo-oslo-python-3
+* https://etherpad.openstack.org/p/kilo-oslo-oslo.messaging
+* https://etherpad.openstack.org/p/py34-transition (tangentially related)
diff --git a/doc/make.bat b/doc/make.bat
new file mode 100644
index 0000000..ff0c47e
--- /dev/null
+++ b/doc/make.bat
@@ -0,0 +1,242 @@
+@ECHO OFF
+
+REM Command file for Sphinx documentation
+
+if "%SPHINXBUILD%" == "" (
+ set SPHINXBUILD=sphinx-build
+)
+set BUILDDIR=_build
+set ALLSPHINXOPTS=-d %BUILDDIR%/doctrees %SPHINXOPTS% .
+set I18NSPHINXOPTS=%SPHINXOPTS% .
+if NOT "%PAPER%" == "" (
+ set ALLSPHINXOPTS=-D latex_paper_size=%PAPER% %ALLSPHINXOPTS%
+ set I18NSPHINXOPTS=-D latex_paper_size=%PAPER% %I18NSPHINXOPTS%
+)
+
+if "%1" == "" goto help
+
+if "%1" == "help" (
+ :help
+ echo.Please use `make ^<target^>` where ^<target^> is one of
+ echo. html to make standalone HTML files
+ echo. dirhtml to make HTML files named index.html in directories
+ echo. singlehtml to make a single large HTML file
+ echo. pickle to make pickle files
+ echo. json to make JSON files
+ echo. htmlhelp to make HTML files and a HTML help project
+ echo. qthelp to make HTML files and a qthelp project
+ echo. devhelp to make HTML files and a Devhelp project
+ echo. epub to make an epub
+ echo. latex to make LaTeX files, you can set PAPER=a4 or PAPER=letter
+ echo. text to make text files
+ echo. man to make manual pages
+ echo. texinfo to make Texinfo files
+ echo. gettext to make PO message catalogs
+ echo. changes to make an overview over all changed/added/deprecated items
+ echo. xml to make Docutils-native XML files
+ echo. pseudoxml to make pseudoxml-XML files for display purposes
+ echo. linkcheck to check all external links for integrity
+ echo. doctest to run all doctests embedded in the documentation if enabled
+ goto end
+)
+
+if "%1" == "clean" (
+ for /d %%i in (%BUILDDIR%\*) do rmdir /q /s %%i
+ del /q /s %BUILDDIR%\*
+ goto end
+)
+
+
+%SPHINXBUILD% 2> nul
+if errorlevel 9009 (
+ echo.
+ echo.The 'sphinx-build' command was not found. Make sure you have Sphinx
+ echo.installed, then set the SPHINXBUILD environment variable to point
+ echo.to the full path of the 'sphinx-build' executable. Alternatively you
+ echo.may add the Sphinx directory to PATH.
+ echo.
+ echo.If you don't have Sphinx installed, grab it from
+ echo.http://sphinx-doc.org/
+ exit /b 1
+)
+
+if "%1" == "html" (
+ %SPHINXBUILD% -b html %ALLSPHINXOPTS% %BUILDDIR%/html
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished. The HTML pages are in %BUILDDIR%/html.
+ goto end
+)
+
+if "%1" == "dirhtml" (
+ %SPHINXBUILD% -b dirhtml %ALLSPHINXOPTS% %BUILDDIR%/dirhtml
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished. The HTML pages are in %BUILDDIR%/dirhtml.
+ goto end
+)
+
+if "%1" == "singlehtml" (
+ %SPHINXBUILD% -b singlehtml %ALLSPHINXOPTS% %BUILDDIR%/singlehtml
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished. The HTML pages are in %BUILDDIR%/singlehtml.
+ goto end
+)
+
+if "%1" == "pickle" (
+ %SPHINXBUILD% -b pickle %ALLSPHINXOPTS% %BUILDDIR%/pickle
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished; now you can process the pickle files.
+ goto end
+)
+
+if "%1" == "json" (
+ %SPHINXBUILD% -b json %ALLSPHINXOPTS% %BUILDDIR%/json
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished; now you can process the JSON files.
+ goto end
+)
+
+if "%1" == "htmlhelp" (
+ %SPHINXBUILD% -b htmlhelp %ALLSPHINXOPTS% %BUILDDIR%/htmlhelp
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished; now you can run HTML Help Workshop with the ^
+.hhp project file in %BUILDDIR%/htmlhelp.
+ goto end
+)
+
+if "%1" == "qthelp" (
+ %SPHINXBUILD% -b qthelp %ALLSPHINXOPTS% %BUILDDIR%/qthelp
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished; now you can run "qcollectiongenerator" with the ^
+.qhcp project file in %BUILDDIR%/qthelp, like this:
+ echo.^> qcollectiongenerator %BUILDDIR%\qthelp\aiogreen.qhcp
+ echo.To view the help file:
+ echo.^> assistant -collectionFile %BUILDDIR%\qthelp\aiogreen.ghc
+ goto end
+)
+
+if "%1" == "devhelp" (
+ %SPHINXBUILD% -b devhelp %ALLSPHINXOPTS% %BUILDDIR%/devhelp
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished.
+ goto end
+)
+
+if "%1" == "epub" (
+ %SPHINXBUILD% -b epub %ALLSPHINXOPTS% %BUILDDIR%/epub
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished. The epub file is in %BUILDDIR%/epub.
+ goto end
+)
+
+if "%1" == "latex" (
+ %SPHINXBUILD% -b latex %ALLSPHINXOPTS% %BUILDDIR%/latex
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished; the LaTeX files are in %BUILDDIR%/latex.
+ goto end
+)
+
+if "%1" == "latexpdf" (
+ %SPHINXBUILD% -b latex %ALLSPHINXOPTS% %BUILDDIR%/latex
+ cd %BUILDDIR%/latex
+ make all-pdf
+ cd %BUILDDIR%/..
+ echo.
+ echo.Build finished; the PDF files are in %BUILDDIR%/latex.
+ goto end
+)
+
+if "%1" == "latexpdfja" (
+ %SPHINXBUILD% -b latex %ALLSPHINXOPTS% %BUILDDIR%/latex
+ cd %BUILDDIR%/latex
+ make all-pdf-ja
+ cd %BUILDDIR%/..
+ echo.
+ echo.Build finished; the PDF files are in %BUILDDIR%/latex.
+ goto end
+)
+
+if "%1" == "text" (
+ %SPHINXBUILD% -b text %ALLSPHINXOPTS% %BUILDDIR%/text
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished. The text files are in %BUILDDIR%/text.
+ goto end
+)
+
+if "%1" == "man" (
+ %SPHINXBUILD% -b man %ALLSPHINXOPTS% %BUILDDIR%/man
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished. The manual pages are in %BUILDDIR%/man.
+ goto end
+)
+
+if "%1" == "texinfo" (
+ %SPHINXBUILD% -b texinfo %ALLSPHINXOPTS% %BUILDDIR%/texinfo
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished. The Texinfo files are in %BUILDDIR%/texinfo.
+ goto end
+)
+
+if "%1" == "gettext" (
+ %SPHINXBUILD% -b gettext %I18NSPHINXOPTS% %BUILDDIR%/locale
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished. The message catalogs are in %BUILDDIR%/locale.
+ goto end
+)
+
+if "%1" == "changes" (
+ %SPHINXBUILD% -b changes %ALLSPHINXOPTS% %BUILDDIR%/changes
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.The overview file is in %BUILDDIR%/changes.
+ goto end
+)
+
+if "%1" == "linkcheck" (
+ %SPHINXBUILD% -b linkcheck %ALLSPHINXOPTS% %BUILDDIR%/linkcheck
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Link check complete; look for any errors in the above output ^
+or in %BUILDDIR%/linkcheck/output.txt.
+ goto end
+)
+
+if "%1" == "doctest" (
+ %SPHINXBUILD% -b doctest %ALLSPHINXOPTS% %BUILDDIR%/doctest
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Testing of doctests in the sources finished, look at the ^
+results in %BUILDDIR%/doctest/output.txt.
+ goto end
+)
+
+if "%1" == "xml" (
+ %SPHINXBUILD% -b xml %ALLSPHINXOPTS% %BUILDDIR%/xml
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished. The XML files are in %BUILDDIR%/xml.
+ goto end
+)
+
+if "%1" == "pseudoxml" (
+ %SPHINXBUILD% -b pseudoxml %ALLSPHINXOPTS% %BUILDDIR%/pseudoxml
+ if errorlevel 1 exit /b 1
+ echo.
+ echo.Build finished. The pseudo-XML files are in %BUILDDIR%/pseudoxml.
+ goto end
+)
+
+:end