summaryrefslogtreecommitdiff
path: root/README
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2014-11-19 03:10:45 +0100
committerVictor Stinner <victor.stinner@gmail.com>2014-11-19 03:10:45 +0100
commit5c28a55e01668cfccc00d8d435a046bf764df9b3 (patch)
tree4e4dd01b9188e68211eebdca5201520653f998ed /README
parentecc85c2b0e936d81a463477a457f2d8fc151532b (diff)
downloadaioeventlet-5c28a55e01668cfccc00d8d435a046bf764df9b3.tar.gz
add a setup.py
Diffstat (limited to 'README')
-rw-r--r--README41
1 files changed, 37 insertions, 4 deletions
diff --git a/README b/README
index 1ddaf80..4dc45ab 100644
--- a/README
+++ b/README
@@ -1,6 +1,34 @@
asyncio event loop scheduling callbacks in eventlet.
-Implemented:
+See also the Trollius project:
+http://trollius.readthedocs.org/
+
+Status
+------
+
+The version 0.1 is the first public release. It was not tested on any project
+yet.
+
+
+Installation
+------------
+
+Requirements:
+
+- eventlet (it was tested with eventlet 0.15)
+- trollius 1.0 or newer
+
+Type::
+
+ pip install aiogreen
+
+or::
+
+ python setup.py install
+
+
+Implemented
+-----------
* call_at()
* call_later()
@@ -11,7 +39,9 @@ Implemented:
* stop()
* coroutines and tasks
-Not supported:
+
+Not supported (yet)
+-------------------
* run an event loop in a thread different than the main thread
* sockets: create_connection, create_server, sock_recv
@@ -19,14 +49,17 @@ Not supported:
* subprocesses: need pipes
* signal handlers: add_signal_handler (only for pyevent hub?)
-Todo:
+
+To do
+-----
* Write new unit tests, or split Tulip test suite between implementation tests
and specification tests
* Support eventlet without monkey-patching
* Test with Python 2 and 3
* Test with Trollius and asyncio
-* Glue to ease debug: keep traceback between Handle, coroutine and greenthread
+* Glue to ease debug: keep traceback between Handle, coroutine and greenthread.
+ Is it even possible?
* run_in_executor(): use eventlet.tpool as the default executor?
It avoids the dependency to concurrent.futures. aiogreen is written as a
temporary solution to switch from eventlet to asyncio. So it may be better to