summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--doc/changelog.rst4
-rw-r--r--setup.py14
2 files changed, 14 insertions, 4 deletions
diff --git a/doc/changelog.rst b/doc/changelog.rst
index ef98cd1..ef5e6cf 100644
--- a/doc/changelog.rst
+++ b/doc/changelog.rst
@@ -1,8 +1,8 @@
Changelog
=========
-Version 0.5
------------
+2016-02-22: Version 0.5
+-----------------------
* Unit tests now use the aiotest library.
* Fix for eventlet used with monkey-patching: inject the original threading
diff --git a/setup.py b/setup.py
index 9db91a1..712b54d 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,5 @@
-# Release procedure:
+# Prepare a release:
+#
# - fill the changelog
# - run unit tests on Linux: run "tox"
# - run unit tests on Windows, run::
@@ -7,15 +8,24 @@
# \Python27\python.exe runtest.py -r -m
#
# - update the version in setup.py and doc/conf.py to X.Y
-# - set release date in doc/changelog.rst
# - check that "python setup.py sdist" contains all files tracked by
# the SCM (Mercurial): update MANIFEST.in if needed
+# - set release date in doc/changelog.rst
# - hg ci
+# - hg push
+#
+# Release a new version:
+#
# - hg tag X.Y
# - hg push
# - python setup.py sdist bdist_wheel register upload
# - increment version in setup.py and doc/conf.py
# - hg ci && hg push
+#
+# After the release:
+#
+# - increment version in setup.py and doc/conf.py
+# - hg ci -m "post-release" && hg push
import sys
try: