summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2019-09-20 14:45:36 -0400
committerMike Bayer <mike_mp@zzzcomputing.com>2019-09-20 14:45:36 -0400
commit68ca631575a812f4f36e7521f11f4f351833282d (patch)
tree00b0f7fbf7412733cb5c7401d13362e03fbfedc5
parent3496f19cd52c89f05ca0a8af32adb141caa3db8d (diff)
downloadalembic-68ca631575a812f4f36e7521f11f4f351833282d.tar.gz
Remove tests_require
Removed the "test requirements" from "setup.py test", as this command now only emits a removal error in any case and these requirements are unused. Change-Id: I53a798bdedad88d8f9708ed3fb6d8ed1aa49f526 Fixes: #592
-rw-r--r--docs/build/unreleased/592.rst6
-rw-r--r--setup.py1
2 files changed, 6 insertions, 1 deletions
diff --git a/docs/build/unreleased/592.rst b/docs/build/unreleased/592.rst
new file mode 100644
index 0000000..9f5f369
--- /dev/null
+++ b/docs/build/unreleased/592.rst
@@ -0,0 +1,6 @@
+.. change::
+ :tags: bug, tests
+ :tickets: 592
+
+ Removed the "test requirements" from "setup.py test", as this command now
+ only emits a removal error in any case and these requirements are unused.
diff --git a/setup.py b/setup.py
index 52c764e..7fbf4be 100644
--- a/setup.py
+++ b/setup.py
@@ -72,7 +72,6 @@ setup(
license="MIT",
packages=find_packages(".", exclude=["examples*", "test*"]),
include_package_data=True,
- tests_require=["pytest!=3.9.1,!=3.9.2", "mock", "Mako"],
cmdclass={"test": UseTox},
zip_safe=False,
install_requires=requires,