summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Bayer <mike_mp@zzzcomputing.com>2019-06-03 12:52:12 -0400
committerMike Bayer <mike_mp@zzzcomputing.com>2019-06-03 15:59:15 -0400
commita8b60b4ad9fe8339629da9ce41853519460abb15 (patch)
treee7f9291e4a323325a9754686e22eb22e0f280cad
parent41b100e6300e0680e9457149ac6f36ad7f78909e (diff)
downloadalembic-a8b60b4ad9fe8339629da9ce41853519460abb15.tar.gz
Add "usecase" changelog tag
"usecase" indicates the library now supports something a user was trying to do. It's not quite a "feature" since it's something that seems like it should have worked, it's not a "bug" because no mistake was made, it's just something that wasn't considered before. The advantage of "usecase" is that it inherently suggests a different style of prioritization vs. something that is preventing the library from working as designed. This change also adds docs/build/conf.py under the pep8 formatting test coverage, and additionally moves release / release_date to be present within; the release scripts will be altered to include this. Change-Id: Iea071a320e7a3672b35a41b13d5a74c0da5f9074
-rw-r--r--docs/build/conf.py150
-rw-r--r--tox.ini2
2 files changed, 87 insertions, 65 deletions
diff --git a/docs/build/conf.py b/docs/build/conf.py
index 09d9b6a..1838702 100644
--- a/docs/build/conf.py
+++ b/docs/build/conf.py
@@ -3,7 +3,8 @@
# Alembic documentation build configuration file, created by
# sphinx-quickstart on Sat May 1 12:47:55 2010.
#
-# This file is execfile()d with the current directory set to its containing dir.
+# This file is execfile()d with the current directory set to its containing
+# dir.
#
# Note that not all possible configuration values are present in this
# autogenerated file.
@@ -11,30 +12,43 @@
# All configuration values have a default; values that are commented out
# serve to show the default.
-import sys
import os
+import sys
+
# If extensions (or modules to document with autodoc) are in another directory,
# add these directories to sys.path here. If the directory is relative to the
# documentation root, use os.path.abspath to make it absolute, like shown here.
-sys.path.append(os.path.abspath('.'))
+sys.path.append(os.path.abspath("."))
# If your extensions are in another directory, add it here. If the directory
# is relative to the documentation root, use os.path.abspath to make it
# absolute, like shown here.
-sys.path.insert(0, os.path.abspath('../../'))
+sys.path.insert(0, os.path.abspath("../../"))
-import alembic
+if True:
+ import alembic # noqa
-# -- General configuration -----------------------------------------------------
+# -- General configuration ---------------------------------------------------
-# Add any Sphinx extension module names here, as strings. They can be extensions
-# coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
-extensions = ['sphinx.ext.autodoc', 'sphinx.ext.intersphinx',
- 'changelog', 'sphinx_paramlinks']
+# Add any Sphinx extension module names here, as strings. They can be
+# extensions coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
+extensions = [
+ "sphinx.ext.autodoc",
+ "sphinx.ext.intersphinx",
+ "changelog",
+ "sphinx_paramlinks",
+]
# tags to sort on inside of sections
-changelog_sections = ["changed", "feature", "bug", "moved", "removed"]
+changelog_sections = [
+ "changed",
+ "feature",
+ "bug",
+ "usecase",
+ "moved",
+ "removed",
+]
changelog_render_ticket = "https://github.com/sqlalchemy/alembic/issues/%s"
changelog_render_pullreq = "https://github.com/sqlalchemy/alembic/pull/%s"
@@ -47,22 +61,22 @@ changelog_render_pullreq = {
autodoc_default_flags = ["members"]
# Add any paths that contain templates here, relative to this directory.
-templates_path = ['_templates']
+templates_path = ["_templates"]
# The suffix of source filenames.
-source_suffix = '.rst'
+source_suffix = ".rst"
# The encoding of source files.
-#source_encoding = 'utf-8'
+# source_encoding = 'utf-8'
nitpicky = True
# The master toctree document.
-master_doc = 'index'
+master_doc = "index"
# General information about the project.
-project = u'Alembic'
-copyright = u'2010-2019, Mike Bayer'
+project = u"Alembic"
+copyright = u"2010-2019, Mike Bayer" # noqa
# The version info for the project you're documenting, acts as replacement for
# |version| and |release|, also used in various other places throughout the
@@ -71,52 +85,54 @@ copyright = u'2010-2019, Mike Bayer'
# The short X.Y version.
version = alembic.__version__
# The full version, including alpha/beta/rc tags.
-release = alembic.__version__
+release = "1.0.10"
+release_date = "April 28, 2019"
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
-#language = None
+# language = None
# There are two options for replacing |today|: either, you set today to some
# non-false value, then it is used:
-#today = ''
+# today = ''
# Else, today_fmt is used as the format for a strftime call.
-#today_fmt = '%B %d, %Y'
+# today_fmt = '%B %d, %Y'
# List of documents that shouldn't be included in the build.
-#unused_docs = []
+# unused_docs = []
# List of directories, relative to source directory, that shouldn't be searched
# for source files.
exclude_trees = []
-# The reST default role (used for this markup: `text`) to use for all documents.
-#default_role = None
+# The reST default role (used for this markup: `text`) to use for all
+# documents.
+# default_role = None
# If true, '()' will be appended to :func: etc. cross-reference text.
-#add_function_parentheses = True
+# add_function_parentheses = True
# If true, the current module name will be prepended to all description
# unit titles (such as .. function::).
-#add_module_names = True
+# add_module_names = True
# If true, sectionauthor and moduleauthor directives will be shown in the
# output. They are ignored by default.
-#show_authors = False
+# show_authors = False
# The name of the Pygments (syntax highlighting) style to use.
-pygments_style = 'sphinx'
+pygments_style = "sphinx"
# A list of ignored prefixes for module index sorting.
-#modindex_common_prefix = []
+# modindex_common_prefix = []
-# -- Options for HTML output ---------------------------------------------------
+# -- Options for HTML output ------------------------------------------------
# The theme to use for HTML and HTML Help pages. Major themes that come with
# Sphinx are currently 'default' and 'sphinxdoc'.
-html_theme = 'nature'
+html_theme = "nature"
html_style = "nature_override.css"
@@ -124,109 +140,115 @@ html_style = "nature_override.css"
# Theme options are theme-specific and customize the look and feel of a theme
# further. For a list of options available for each theme, see the
# documentation.
-#html_theme_options = {}
+# html_theme_options = {}
# Add any paths that contain custom themes here, relative to this directory.
-#html_theme_path = []
+# html_theme_path = []
# The name for this set of Sphinx documents. If None, it defaults to
# "<project> v<release> documentation".
-#html_title = None
+# html_title = None
# A shorter title for the navigation bar. Default is the same as html_title.
-#html_short_title = None
+# html_short_title = None
# The name of an image file (relative to this directory) to place at the top
# of the sidebar.
-#html_logo = None
+# html_logo = None
# The name of an image file (within the static path) to use as favicon of the
# docs. This file should be a Windows icon file (.ico) being 16x16 or 32x32
# pixels large.
-#html_favicon = None
+# html_favicon = None
# Add any paths that contain custom static files (such as style sheets) here,
# relative to this directory. They are copied after the builtin static files,
# so a file named "default.css" will overwrite the builtin "default.css".
-html_static_path = ['_static']
+html_static_path = ["_static"]
# If not '', a 'Last updated on:' timestamp is inserted at every page bottom,
# using the given strftime format.
-#html_last_updated_fmt = '%b %d, %Y'
+# html_last_updated_fmt = '%b %d, %Y'
# If true, SmartyPants will be used to convert quotes and dashes to
# typographically correct entities.
-#html_use_smartypants = True
+# html_use_smartypants = True
# Custom sidebar templates, maps document names to template names.
-html_sidebars = {"**": ["site_custom_sidebars.html", "localtoc.html", "searchbox.html", "relations.html"]}
+html_sidebars = {
+ "**": [
+ "site_custom_sidebars.html",
+ "localtoc.html",
+ "searchbox.html",
+ "relations.html",
+ ]
+}
# Additional templates that should be rendered to pages, maps page names to
# template names.
-#html_additional_pages = {}
+# html_additional_pages = {}
# If false, no module index is generated.
-#html_use_modindex = True
+# html_use_modindex = True
# If false, no index is generated.
-#html_use_index = True
+# html_use_index = True
# If true, the index is split into individual pages for each letter.
-#html_split_index = False
+# html_split_index = False
# If true, links to the reST sources are added to the pages.
-#html_show_sourcelink = True
+# html_show_sourcelink = True
# If true, an OpenSearch description file will be output, and all pages will
# contain a <link> tag referring to it. The value of this option must be the
# base URL from which the finished HTML is served.
-#html_use_opensearch = ''
+# html_use_opensearch = ''
# If nonempty, this is the file name suffix for HTML files (e.g. ".xhtml").
-#html_file_suffix = ''
+# html_file_suffix = ''
# Output file base name for HTML help builder.
-htmlhelp_basename = 'Alembicdoc'
+htmlhelp_basename = "Alembicdoc"
-# -- Options for LaTeX output --------------------------------------------------
+# -- Options for LaTeX output -----------------------------------------------
# The paper size ('letter' or 'a4').
-#latex_paper_size = 'letter'
+# latex_paper_size = 'letter'
# The font size ('10pt', '11pt' or '12pt').
-#latex_font_size = '10pt'
+# latex_font_size = '10pt'
-# Grouping the document tree into LaTeX files. List of tuples
-# (source start file, target name, title, author, documentclass [howto/manual]).
+# Grouping the document tree into LaTeX files. List of tuples (source start
+# file, target name, title, author, documentclass [howto/manual]).
latex_documents = [
- ('index', 'Alembic.tex', u'Alembic Documentation',
- u'Mike Bayer', 'manual'),
+ ("index", "Alembic.tex", u"Alembic Documentation", u"Mike Bayer", "manual")
]
# The name of an image file (relative to this directory) to place at the top of
# the title page.
-#latex_logo = None
+# latex_logo = None
# For "manual" documents, if this is true, then toplevel headings are parts,
# not chapters.
-#latex_use_parts = False
+# latex_use_parts = False
# Additional stuff for the LaTeX preamble.
-#latex_preamble = ''
+# latex_preamble = ''
# Documents to append as an appendix to all manuals.
-#latex_appendices = []
+# latex_appendices = []
# If false, no module index is generated.
-#latex_use_modindex = True
+# latex_use_modindex = True
-#{'python': ('http://docs.python.org/3.2', None)}
+# {'python': ('http://docs.python.org/3.2', None)}
autoclass_content = "both"
intersphinx_mapping = {
- 'sqla':('http://www.sqlalchemy.org/docs/', None),
- 'python':('http://docs.python.org/', None),
+ "sqla": ("http://www.sqlalchemy.org/docs/", None),
+ "python": ("http://docs.python.org/", None),
}
diff --git a/tox.ini b/tox.ini
index 67c734a..2b238f4 100644
--- a/tox.ini
+++ b/tox.ini
@@ -67,4 +67,4 @@ deps=
flake8-rst-docstrings
# used by flake8-rst-docstrings
pygments
-commands = flake8 ./alembic/ ./tests/ setup.py
+commands = flake8 ./alembic/ ./tests/ setup.py docs/build/conf.py